Tridion Stack Exchange is a question and answer site for Tridion developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up my first DXA / Web 8 Installation, and i'm met with the following error when hitting the web app:

Invalid v2 service endpoint for content-service

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Sdl.Web.Delivery.Service.InvalidServiceEndpoint: Invalid v2 service endpoint for content-service

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[InvalidServiceEndpoint: Invalid v2 service endpoint for content-service]
Sdl.Web.Delivery.ContentService.AutoConfigure.get_ODataV2ServiceEndpoint() +180 Sdl.Web.Delivery.ContentService.ContentServiceClient..ctor(IContentServiceConfiguration serviceConfiguration) +96
Sdl.Web.Delivery.Dynamic.DynamicMappingsRetrieverImpl.GetPublicationMapping(String url) +191
Sdl.Web.Tridion.CdApiLocalizationResolver.ResolveLocalization(Uri url) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Tridion\CdApiLocalizationResolver.cs:67
Sdl.Web.Mvc.Configuration.WebRequestContext.get_Localization() in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Configuration\WebRequestContext.cs:23
Sdl.Web.Mvc.Statics.StaticContentModule.BeginRequest(Object sender, EventArgs e) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Statics\StaticContentModule.cs:85
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

I've checked the configs and the urls of my content services and these seem to be correct, i'm wondering what i'm missing?

The Web App log is showing:

  Registering OData V2 Service:

http://localhost:8083/client/v4/content.svc/ 2016-03-07 16:56:21 WARN [Sdl.Web.Delivery.Service.<>c__DisplayClass211.<Execute>b__1f] - Failed to execute query. 2016-03-07 17:05:15 INFO [Sdl.Web.Delivery.Dynamic.DynamicMappingsRetrieverImpl.GetPublicationMapping] - Creating content-service client. 2016-03-07 17:05:15 INFO [Sdl.Web.Delivery.ContentService.ContentServiceClient..ctor] Registering OData V2 Service: http://localhost:8083/client/v2/content.svc/ 2016-03-07 17:05:15 INFO [Sdl.Web.Delivery.ContentService.ContentServiceClient..ctor] Registering OData V2 Service: http://localhost:8083/client/v4/content.svc/ 2016-03-07 17:05:15 WARN [Sdl.Web.Delivery.Service.<>c__DisplayClass211.b__1f] - Failed to execute query.

This URL does correctly load my content service.

Any steps to trouble shoot this would be appreciated.

Thanks

share|improve this question

Solved it, I re-ran:

Java –jar discovery-registration.jar update located in the /config folder of my discovery service

:)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.