Take the 2-minute tour ×
Tridion Stack Exchange is a question and answer site for Tridion developers and administrators. It's 100% free, no registration required.

I am not able to view the toolbar (button) to start editing the fields via Experience Manager. View source of my published page is:

  <div>
    <span>
      <!-- Start Component Presentation: {"ComponentID" : "tcm:16-1712", "ComponentModified" : "2014-04-04T07:02:24", "ComponentTemplateID" : "tcm:16-1922-32", "ComponentTemplateModified" : "2014-04-14T10:31:33", "IsRepositoryPublished" : false } --> 
      <span>
        <!-- Start Component Field: {"XPath":"tcm:Content/custom:Content/custom:text[1]"} -->
        Maxi Centrefeed Dispenser
      </span>
    </span>
  </div>

  <!-- Page Settings: {"PageID":"tcm:16-1924-64","PageModified":"2014-04-11T11:29:41","PageTemplateID":"tcm:16-1920-128","PageTemplateModified":"2014-04-14T10:27:54"} -->
  <script type="text/javascript" language="javascript" defer="defer" src="http://localhost/WebUI/Editors/SiteEdit/Views/Bootstrap/Bootstrap.aspx?mode=js" id="tridion.siteedit"></script>
</body>

See also the attached image, is anything missing here?

enter image description here

enter image description here

share|improve this question
    
did you request the page on the Tridion CM server? –  Siawash Shibani Apr 14 at 12:48

2 Answers 2

  1. Your URL says "localhost" - are you loading this page on the server, or from a remote client? You should change the URL parameter in your "Enable Inline Editing" TBB to use the real server name.

  2. Does the button load on the top left corner at all?

share|improve this answer

From a technical standpoint the XPM markup on the page is correct, syntactically correct that is. I would expect that it works on the CM server directly, assuming that you can request the url http://localhost on there and that it would load the CME correctly.

If that assumption is correct, then your problem isn't directly in the Page, but actually in the Enable inline editing for Page Template Building Block on your Page Template. To solve it you will want to change the SiteEdit Editor URL parameter for that TBB (in your Page Template) to contain a URL that you can request not only on the CM server, but also outside it.

Next to that you will also want to add the URL of your SiteEdit/XPM enabled website (usually Staging) to the Session Preview tab of the Publication Target you use for Experience Manager (again, usually Staging).

share|improve this answer
    
If all that is done, and you still dont see any button on the top left corner; Do you see any errors in your browser console ? –  jarnohenneman Apr 14 at 13:07
    
Thanks all, I guess localhost was the an issue. Plz see the image and let me know if it looks like the same. –  user918 Apr 15 at 5:29
    
The image looks like you can actually see the SDL Tridion button, so all good there. Are you able to login and see the Experience Manager toolbar when clicking on this button? Also, make sure to use the hostname of the server instead of localhost as Bart and Nuno mentioned for remote access. –  Philippe Conil Apr 15 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.