Take the 2-minute tour ×
Tridion Stack Exchange is a question and answer site for Tridion developers and administrators. It's 100% free, no registration required.

I am implementing Experience Manager with DD4T solution.

Everything working fine except there is no border highlighted for Component content. It is highlighted for Page. Please suggest the probable area of issue.

Markup for the Component Presentations and Page is as below:

<section class="main" role="main">
    <figure id="ball-box" class="widgetContainer">
        <!-- Start Component Presentation: {"ComponentID" : "tcm:33-1690", "ComponentModified" : "2014-07-30T16:49:20", "ComponentTemplateID" : "tcm:33-1863-32", "ComponentTemplateModified" : "2014-07-25T09:15:42", "IsRepositoryPublished" : false} -->
           <figcaption id="homeWidget" class="homepage widget">
                <h2><!-- Start Component Field: {"XPath":"tcm:Content/custom:HomePageWidget/custom:Header[1]"} -->Component Text1</h2>
                <text><!-- Start Component Field: {"XPath":"tcm:Content/custom:HomePageWidget/custom:Description[1]"} -->Component Text2</text>
                <a href="/Services/" class="learn-more"><!-- Start Component Field: {"XPath":"tcm:Content/custom:HomePageWidget/custom:Link[1]/custom:LinkText[1]"} --> component Text3</a>
           </figcaption>
   </figure>
</section>
 <!-- Page Settings: {"PageID":"tcm:33-1859-64","PageModified":"2014-07-31T11:41:14","PageTemplateID":"tcm:33-1860-128","PageTemplateModified":"2014-07-29T06:44:37"} --><script type="text/javascript" language="javascript" defer="defer" src="<cms-url>/WebUI/Editors/SiteEdit/Views/Bootstrap/Bootstrap.aspx?mode=js" id="tridion.siteedit"></script>
share|improve this question
    
Based on Bart's answer, the CSS can help troubleshoot as well. I'm also thinking JSFiddle or similar all-in-one front-end tools could help with this types of questions. :-) –  Alvin Reyes Jul 31 at 18:22

3 Answers 3

up vote 3 down vote accepted

Content border issue related to HTML element. Please make sure every field must be enclosed in a html tag.

share|improve this answer
    
You are right Manish.. –  Mukesh Kumar Aug 5 at 14:21

The generated markup looks okay, every XPM comment has its own unique HTML container, so I'm expecting all the borders to be there. The only thing which could be an issue then is that you are not able to reach some of the borders, since they might be overlapping.

Take this for example:

<div id="ComponentPresentation">
  <!-- Start Component Presentation: {...} -->
  <div id="Field">
    <!-- Start Component Field: {...} -->
    Text
  <div>
</div>

Without any styling, the border for the Component Presentation and the border for the Field will overlap. This means you should still be able to reach the Field, since when yo hover over the text the border of the Field will be activated. You might still get to see the Border of the Component Presentation, but it will be impossible to select it without selecting the Field. However once you selected the Field, you will have selected the Component Presentation too, so most of the time this is not a problem (for the Page the same thing counts, but there is another HTML container which has the Page border, which could be the same size as your Component Presentation border).

But with styling this can become a complete different story, it all depends on the styling. Styling can make it better or worse, ideally you would have your site styling in such a way that there is room between the Component Presentation div and the Field div, but if there isn't I'd first see if what is there is usable before you consider updating the styling. As a last resort you could always consider to have a different styling on the Staging/XPM Preview site, for tips on how to accomplish that, take a look at this blog article.

share|improve this answer
    
Thanks Bart, I have marked your comment as a answer for my question. –  Mukesh Kumar Aug 1 at 6:01

Please check your site_edit_config.xml settings. I think I have seen this for fields when the settings there do not exist for the current Publication.

For example:

<?xml version="1.0" encoding="utf-8"?>
<siteEdit enabled="true" style="SiteEdit2012" tridionHostUrl="http://cmsurl">
  <contextPublications>
    <contextPublication id="128" pagePublication="128" componentPublication="125" publishPublication="128"/>
    <contextPublication id="130" pagePublication="130" componentPublication="125" publishPublication="130"/>
    <contextPublication id="131" pagePublication="131" componentPublication="125" publishPublication="131"/>
  </contextPublications>
</siteEdit>
share|improve this answer
    
I thought the Publication context settings were set in the dashboard itself. Do these still apply, Rob? –  Alvin Reyes Jul 31 at 18:18
    
They shouldn't but unfortunately due to what I guess is a bug in DD4T the context is still checked by a method called in the Html.SiteEditField Html Helper method. I've reported the issue code.google.com/p/dynamic-delivery-4-tridion/issues/…. Hopefully we'll be able to get onto it soon! –  Rob Stevenson-Leggett Jul 31 at 18:31
    
Oh, okay. +1 then, with a caveat that this only applies to XPM with DD4T circa July 2014. :-) –  Alvin Reyes Jul 31 at 18:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.