2

Don't know why Translation job flow which was working fine couple of days back stopped working and generating below in log:

The description for Event ID 0 from source Translation Manager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

The translation configuration for the item tcm:0-229-1 could not be loaded.
The Item with id "tcm:0-229-1" has an invalid translation configuration.
The remote server returned an error: (407) Proxy Authentication Required.

StackTrace Information Details:
   at Tridion.TranslationManager.DomainModel.TranslationConfiguration.LoadDirectlyConfiguredOnly(TcmUri configuredItemId, Boolean allowConfigurationErrors, UserContext userContext)
   at Tridion.TranslationManager.DomainModel.TranslationConfiguration.LoadOrgItemInheritedConfiguration(IEnumerable`1 itemPathToRoot, UserContext userContext)
   at Tridion.TranslationManager.DomainModel.TranslationConfiguration.LoadOrgItemInheritedConfiguration(TcmUri itemId, UserContext userContext, TcmItem preloadedTcmItem)
   at Tridion.TranslationManager.DomainModel.TranslationJob..ctor(UserContext userContext, Int32 id, String title, TranslationJobState state, Boolean hasError, TranslationJobPriority priority, DateTime creationDate, DateTime lastChangedDate, TcmUri creatorUri, String creatorName, String creatorDescription, TcmUri lastChangedUserUri, String lastChangedUserName, String lastChangedUserDescription, TcmUri contextItemUri, TranslationJobType type, SelectedWorkflows workflows, IEnumerable`1 targetPublicationUris, IEnumerable`1 addedItems, String businessUnitId, IEnumerable`1 errors, Int32 totalErrors, DateTime requiredDate, Boolean includeItemsAlreadyTranslated, Int32 itemsInTranslationSystem, Int32 itemsInTranslationSystemCompleted, IEnumerable`1 workflowStatuses)
   at Tridion.TranslationManager.DomainModel.DataAccess.TranslationJobSqlDal.InstantiateJobFromReader(IDataReader reader, TranslationJobLoadFilters loadFilter, Boolean readRelatedItems)
   at Tridion.TranslationManager.DomainModel.DataAccess.TranslationJobSqlDal.DequeueTmsJobIdForRetrieve(TranslationJobLoadFilters loadFilter)
   at Tridion.TranslationManager.DomainModel.Service.RetrieveFromTranslationTask.Process()
   at Tridion.TranslationManager.DomainModel.Service.ServiceTask.ThreadMethod()


the message resource is present but the message is not found in the string/message table

Any idea!!

  • 2
    (407) Proxy Authentication Required. Looks like someone changed the proxy rules on your network. Not sure if this can be changed - easily or not. Clearly, TM can't connect to the translation server... – Nuno Linhares Apr 29 '13 at 8:24
  • Nuno or there could be some issues at worldserver webservice connection with the given user name and password as I can see the webservice is getting connected if you access your worlderserver service – Manoj Singh Apr 29 '13 at 8:37
  • Why would it reply with an HTTP 407 then? – Nuno Linhares Apr 29 '13 at 8:44
  • Keep in mind that if you do have a proxy that requires authentication, and you're opening the webservice URL from a browser, the browser will authenticate you automatically. The service is connecting with a different account, and is NOT using a browser, so there may be additional configuration needed. – Nuno Linhares Apr 30 '13 at 7:17
3

The translation manager is not able to connect to the Worldserver instance. Translation manager needs to get the configuration for publication 0-229-1 from the worldserver.

verify if you're able to connect to the WS webservice from the Tridion Content manager.

  • Any idea where we can see this as I can see my worldserver webservice given in F:\Tridion\config\TranslationManager.xml is connecting from that server, i.e. the <WorldServer username="xxxxx" password="xxxx">xxxxx.worldserver.com/ws/services</WorldServer> – Manoj Singh Apr 29 '13 at 8:45
  • yes, try to request that url from the browser on the same machine. – Siawash Shibani Apr 29 '13 at 8:58
  • I am able to see the worldserver webservice is displaying his data from that server, there is no issues with webservice any other point to see – Manoj Singh Apr 29 '13 at 9:17
  • check the proxy rules on the network, as Nuno mentioned. – Siawash Shibani Apr 29 '13 at 9:50
  • @SiavashShibani: Hello Siavash, welcome to Tridion Stack Exchange – Siva Charan Apr 29 '13 at 11:55
2

If you can't change the proxy to allow the connection through without the credentials, it might be possible to specify the username/password using the Credential Manager. You would have to do it for the Windows users running the TM service, the application pool, and the COM+ application (from the top of my head, I might have missed one... or more).

I never tried this though, so I would not know exactly how to do it (if at all possible). Notice it is the proxy URL, username, and password you would need to enter, not the information for World Server.

Alternatively you might be able to configure these users to bypass the proxy for the URL of you World Server instance (this can be done with the netsh set proxy command line), but it will of course require that you can reach the World Server instance directly - in some network setups this is not possible as only the proxy can reach the internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.