My Tridion License has got expired and I am in process of replacing it. After replacing the older License with the new one, I can still see the "License Expired" error while trying to login to the CME. Following are few things which I have tried so far:

  • Restarted SDL Tridion Content Manager COM+ Application and IIS
  • Found a License.xml copy in the %Tridion_Home%\bin - Deleted it and tried again
  • Checked the Tridion Content Manager configuration file and verified the License File Path
  • Manually Changing the path of license.xml in the SDL Tridion Configuration Manager and providing it the absolute path
  • Re-starting the Virtual Machine

But even after trying all these, I am still getting the same error - "License Expired" while trying to access the SDL Tridion CME.

Can someone help with what I might be missing?

  • You verified that the license path in the config file was correct and you restarted the machine, so you should be good. Sounds silly, but have you checked that your new license file is correct and valid? Does it have an entry for the CM Kernel, for example, and is the expiry date (and other attributes) correct? Feb 3, 2015 at 11:50
  • 2
    Try to delete the .ezl20ck file in the Tridion bin directory. After that restart everything. Feb 3, 2015 at 11:51
  • David: Thanks but yes I have checked it is valid Albert: Thanks, Yes this is something I might be missing, but actually just restarting the Tridion Service Host service need to be started. Feb 3, 2015 at 12:26

2 Answers 2

  • Have you installed Hotfix TT CM_2013.1.0.88313 - Cumulative hotfix? This fixes an issues when you have more than one person in the TRUSTEES table.

  • Remove the <Tridion Root>\bin\.ez20ck file to be sure and restart everything

  • Are you sure it's not your cd_licenses.xml which has expired also?

  • Thanks Raimond; Restart Everything works - I forgot to restart the Tridion Service Host service. Feb 3, 2015 at 12:18
  • 1
    Just out of curiosity, how did restarting the Host service work when restarting the entire server hadn't? Feb 3, 2015 at 13:22
  • 2
    David: Thats the MS Windows Server Magic - it might seems. To be frank no idea...and actually that's why I posted the Answer...I restarted the machine after replacing all licenses and as it was again giving error I just removed my temp files and browser cache and restarted the COM+ and IIS...but it was not working - I didn't restarted the service as thought it should have already been resterted with the VM - just following Raimond's answer, I did it again and surprisingly it started working :( Feb 3, 2015 at 14:12
  • I remember versions of Tridion where you had to search your entire computer for files that looked anything like .ez20ck - those pesky lock files could be anywhere! Jul 4, 2016 at 13:22

Indeed this Works. I got it working real quick!

Replacing the correct license file in %Tridion_Home%\bin and restarting the

  • COM+ Application
  • Tridion Content Manager Service Host
  • IIS App Pool
  • IIS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.