I recently had to restore iis from a backup (Crypto\RSA\MachineKeys got corrupted) on the content manager server. Now when I pull up the content manager explorer I get "You do not have permission to access SDL Tridion 2009."

I open the link on the page and I get the following error message:

[CheckAccessRights][Intialize] RESID_4537TDSESQLUtilities.GetDatabaseConnectionDataStoreDAL.InitDataStoreBroker.InitDataStoreUtilitiesBL.InitDataStoreSystemBLST.IBLSecurityST_GetUserContextTDSE.Initialize

Any suggestions on what I should look at to get this resolved?

Specs: Tridion version = Tridion 2009 sp1, cm explorer:build, cms:build OS - W2K3 x64 /sp2

Thank you

  • I verified/compared user access rights to specific folders and files against qa and prod environments. user access rights were identical! I checked the web.config and machine.config under (C:\WINDOWS\microsoft.net\Framework\v2.0.50727\CONFIG) and there was no Authentication Mode setup. Verified this in qa and prod environments as well. I tried to grant network service access to the TridionRsaKeyContainer but its said one didn't exist so generated new one and granted NETWORK SERVICE access. However this didn't correct the issue. And last I worked with the dba team and we deleted/recreated the T
    – user1416
    Commented Feb 6, 2015 at 1:28

3 Answers 3


As the error message clearly suggesting, it is related to the fact that you do not have necessary access right. Ensure following:

  • The corresponding Application Pool of the SDL Tridion website is running using the Network Service or with the User having proper rights on the SDL Tridion installation folder
  • The Authentication Mode for the Website in IIS is set to Windows or Basic (depending on whether you are using Windows Authentication or LDAP Authentication)

Not sure if this version of Tridion uses the TridionRsaKeyContainer but seeing how your machine keys got corrupted this might be the problem; could you grant network service (or the account hosting your apppool) access to the container:

aspnet_regiis -pa TridionRsaKeyContainer "NT AUTHORITY\NETWORK SERVICE"

I suspect this is due to the database user configured in the SDL Tridion Content Manager MMC snap-in; you may need to drop the TCMDBUser user from the restored database and then re-create it in SQL Management Studio, or re-map an existing SQL login to a new database user.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.