I am facing error while adding new user to Tridion 2013 SP1. I am not able to find any users from my active directory. There is no log indicating any error. Also there is no LDAP server setup, so I have not done any LDAP setting.

For more detail, My Tridion is installed with a local user created on that machine. Machine on which Tridion is installed is in X(suppose) active directory. I belong to some other active directory(Suppose Y). I can login to Tridion machine using my credential but can't search myself from Tridion Add new user wizard. I can search users from some other active directory(A) but not from active directories X and Y. Tridion is identifying X and Y active directories but not able to search any user from these active directories. When I tried to search all user from X active directory it took more than 2 minutes and return no result.

Can any one suggest if I have missed any configuration.

  • Kindly share the error message Mar 16, 2015 at 13:19
  • 2
    When searching accross domains, the two domains (read Active Directories) mush have a trust with each other. Can you confirm the domain the machine is on has a trust with the domain you need to search users in? Also is your MTSUser account a domain user, and if so from which domain? (you can probabaly best edit your question and update it with some relevant info and an example, like naming the domains/active directories X and Y etc.) Mar 16, 2015 at 13:44
  • Hi Bart, I have not installed Tridion with MTSUser. I have done it with local user account with Admin rights. I have updated the question to provide more details. I can login to Tridion machine with my credential but I can't search it from Tridion Add new user wizard. I hope this will help to suggest some solution.. Mar 16, 2015 at 15:16
  • 1
    I would recommend that you uninstall and re-install with MTS User on Domain instead of having it installed with Local Machin Admin User and then changing your MTS user - This should be fast and saves you from lots of Trouble - Another issue which I was not able to resolve with Tridion 2011 in your scenario was installing the Content Porter Server in 2011 - Might not be a case in your scenario but just a word of advice :) Mar 18, 2015 at 13:59
  • 2
    Like the previous suggestion, I would use the domain mtsuser for installation. It is also possible that your AD just have too many users and Tridion timed out. As a last resort, you can always add the users manually in the TRUSTEES table or add an AddUser gui extension in the CMS
    – Robert Jin
    Mar 18, 2015 at 19:34

3 Answers 3


My issue is resolved now. Earlier issue was because of the security configuration of active directory(Trust and max user result). As suggested by Rob directly adding user to Trustee table and using AddUser GUI is also working fine.


We had a similar issue in 2011 and never resolved it, having never tried any of the above. Users were created (at cost) through some Middleware process.

However we found it was easy enough to work around with the Core Service, setting the UserData.Title as the user id including domain, e.g. ourDomain\someUserId.


public void AddUser(string username, string description) {
    UserData user = new UserData();
        user.Title = username;
        user.Description = description;
        user.IsEnabled = false; //actual configuration is manual
            user = (UserData) service.Create(user, new ReadOptions());
            Logger.Info(string.Format("Successfully created user {0} as {1}", user.Title, user.Id));
        catch (Exception e)
            Logger.Error(string.Format("Could not create user {0} because {1}", user.Title, e.Message))";

This was eventually overloaded to copy another user's permissions on creation.


Increase the time out in the maching.config and you will be able to search your AD Tridion take more time to search

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.