1

We are trying to create the component based on Component Schema which is having the Embedded Schema Fields.The Embedded schema fields are not showing the XML description, instead it is showing XML names.enter image description here

5
  • 1
    Could this be a browser cache issue? I don't have this problem.
    – Nuno Linhares
    Apr 8 '15 at 13:06
  • No Browser Cache Nuno,because we tried in different browser sessions with no of VDI systems.
    – Sree G
    Apr 8 '15 at 13:58
  • 1
    Can you open and re-save your main schema (Detail Aid Page Spread) ? I had something similar before: i had a schema which used an embedded schema. I think made a change in my embedded schema, but those changes never showed up in my components until i re-saved the main schema. Apr 8 '15 at 14:10
  • Even I fallowed the above mentioned steps am not able to fix the issue. Is there any other alternative way to fix.
    – Sree G
    Apr 9 '15 at 6:28
  • Could be worth mentioning that I tried this on a 2013 SP1 with Hotfix Rollup 1 applied. Maybe you're on vanilla SP1 and this was fixed afterwards?
    – Nuno Linhares
    Apr 9 '15 at 12:12
2

I think there has been a (hotfixed) CME defect that caused a Schema containing Embedded Schemas to be "expanded" while saving (i.e. the embedded Schemas would be physically embedded in the XSD instead of being referenced with an xsd:include).

That could go unnoticed until you would port the Schema to another environment, in which case the labels (field descriptions) would go wrong like you mentioned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.