15

I have a timeout (around 30 secs) when using the TcmUploadAssembly tool. Which timeout setting can I change to increase this? Specifying a longer timeout in the command line of the TcmUploadAssembly does not work.

The error is:

    <![CDATA[Unable to save Template Building Block (tcm:0-0-0).]]>
<tcm:Token>RESID_4574</tcm:Token><tcm:Token>RESID_15320</tcm:Token><tcm:Token>tcm:0-0-0</tcm:Token>
</tcm:Line><tcm:Line ErrorCode="8004033F" Cause="true">
<![CDATA[Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.]]>
</tcm:Line><tcm:Line ErrorCode="8004033F" Cause="false">

<![CDATA[A database error occurred while executing Stored Procedure "EDA_ITEMS_UPDATEBINARYCONTENT".]]><tcm:Token>EDA_ITEMS_UPDATEBINARYCONTENT</tcm:Token></tcm:Line>
14

Unless it's a really big DLL you are trying to upload, I would expect the database is not well maintained, things like statistics not up to date, which can make it slow upon saves.

You can try to increase the query timeout values in the MMC snap-in, but I would check database maintenance first. Does it work after updating the statistics (exec sp_updatestats on MS SQL Server)?

  • 1
    If the Stats Update did not fix your problem, this post fixed my issue. – Trevor Bartlett Jan 20 '14 at 19:51
4

Try increasing values in the MMC > Timeout values.

Does it work fine with smaller templates? Is everything else working fine?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.