1. SmartTarget 2014 SP1 environment consists of Indexer node and 2 Query nodes. The 2 query nodes are behind a load balancer.

  2. Topology.txt file looks something like this on hostname01 server:

    instance name | host | preset | indexer | comment

    staging-indexer|hostname01|3|-|Indexer and Preview
    live-query|hostname02|3|staging-indexer|Live Query Server
    live-query|hostname03|3|staging-indexer|Live Query Server
  3. In SmartTarget 2014, when creating a Promotion from Content Manager, content is automatically updated on live query nodes.

  4. In SmartTarget 2011, you had to manually publish the content out to the live nodes using the Business Manager UI.

Questions: How do I get the SmartTarget 2011 behavior back?

Is there a preference setting that will stop content from being automatically synched from staging to live?

Would taking the 2 query entries out of the hostname01 topology.txt file give me the behavior I need?

1 Answer 1


There is a configuration option to turn it off, but then your users would have to open the Business Manager and click Publish 3 times for it to take effect. So I would not recommend that.

Instead, the recommendation is to have 2 SmartTarget lists (and therefore 2 Fredhopper environments) -- one for staging and one for Live. Your current configuration would be for Live. The staging one probably doesn't need a load balancer in front of it.

So you'd end up with two lists in SmartTarget and users can choose when a Promotion is ready to end up on the Live website, at which point they choose the "Copy to" option and choose the Live list. Similar to how they choose to Publish content to Staging or Live.

This approach is explained in more detail in the documentation: Staging and Live environments.

  • Thanks Peter, the link you referenced is very helpful in understanding how Promotions are now managed in Content Management Explorer. Software engineers upgrading from the 2011 version need to take note of this and plan accordingly. Apr 20, 2015 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.