5

I am working on a SmartTarget implementation using DD4T, getting promotions by query. When I click SiteEdit, my XPM is not showing any regions. I followed the steps from SmartTarget promotions not considered part of region in STRI scenario. My output page is below

<!-- Start Promotion Region: {"RegionID": "Banner" } -->
 <span>
   <!-- Start Query: {  
          "RegionID" : "Banner",    
          "MaxItems" : 0,   
          "Experiments" : [     ],  
           "Promotions" : [         
                 {          
                    "PromotionID": "XXX",                             
                    "PromotionTitle": "Hero Banner - Promo", 
                    "IncludedInPage": true,             
                    "Items" : [
                      { 
                         "ComponentID": "tcm:85-XXX-16", 
                         "ComponentTemplateID": "tcm:85-XXX-32", 
                         "IncludedInPage": true 
                       }            
                    ]       
                 }  
          ] }--> 
  <span>
   <!-- Start Promotion: { "PromotionID": "XXX", "RegionID" : "Banner"} --> 
          My CP goes here from smart target query builder
   <!-- End Promotion -->
  </span>
<!-- End Query-->
</span>
 <!-- End SiteEdit Promotional Region -->

Still my regions are not showing up in Page properties when in SiteEdit. Is there any configuration thing am I missing from SiteEdit? Do I need to enable SmartTarget in SiteEdit?

I am using SDL Trdion 2013 SP1 with SmartTarget 2014.

5
  • To add to this question, is there a specific configuration on Tridion Server, or Fredhopper to enable Experience Manager other than the tags shown above Apr 29, 2015 at 21:11
  • By "followed the steps", do you mean that this markup was generated by the GetExperienceManagerMarkup method? If not, I'd double-check that the markup is 100% correct. Also, is there a container element around this markup? The comments always need to be underneath a containing HTML element (like the Start Query line is under the span). Apr 30, 2015 at 7:56
  • As for what configuration is needed: SmartTarget needs to be installed on the CM machine, your staging site need to be configured properly for XPM, the Publication Target associated with the site should have the Targeting tab filled out correctly, and the user needs to have the "Manage Promotions" right (or "Manage Experiments" if using SP1). I think that's all of them, though I may be forgotten something. Apr 30, 2015 at 7:58
  • Thanks Peter. I generated the markup using GetExperienceManagerMarkup. There is a wrapper <div> around it.
    – vinod
    May 1, 2015 at 0:05
  • Could you try changing the first span to a div? You are technically not allowed to have a span inside of a span, so perhaps the browser fixes this for you by separating the two -- resulting in them not being parsed correctly. Jun 22, 2015 at 14:14

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.