3

In our application logs, we see large amounts of warnings saying:

[ WARN] 2015-05-08 16:56:28,012 com.tridion.linking.PageLink:97 - Object cache is enabled but PageMeta Home object isnt in the CacheBindings, PageLink caching will not be enabled [ WARN] 2015-05-08 16:56:28,013 com.tridion.linking.ComponentLink:144 - Object cache is enabled but LinkInfo or PageMeta Home objects arent in the CacheBindings, ComponentLink caching will not be enabled

I've been looking at Component Link Caching Not Working?, but this seems to be a distinct problem, because in our system, caching is correctly configured, using exactly the approach suggested in the answers there.

<ItemTypes defaultStorageId="defaultdb" cached="true">
    <Publication Id="48">
        <Item typeMapping="Page" storageId="fileRoot" cached="false" />
        <Item typeMapping="Binary" storageId="fileRoot" cached="false" />
    </Publication>
    ..... more publications ... 
</ItemTypes>

This is a site with some Experience Manager configurations present, (although not currently in use). I note that in one of the answers to the other question, there is a suggestion that experience manager might be part of the problem.

As far as I can see, the other question takes care of the basic issue of configuring caching. What I'm looking for with this question are insights into how an interaction with experience manager might be relevant.

Update: I am not talking about preview. This is simply about normal use of the staging site.

System: Tridion 2013 SP1 HR1.

EDIT:

Following up on Renze's suggestion, and a few other things, we have now tried various configurations... for example:

<ItemTypes defaultStorageId="defaultdb" cached="true">  
    <Item typeMapping="Metadata" storageId="defaultdb" cached="true" />             
    <Publication Id="48" cached="true">
        <Item typeMapping="Page" storageId="fileRoot" cached="false" />
        <Item typeMapping="Binary" storageId="fileRoot" cached="false" />       
    </Publication>

and

<ItemTypes defaultStorageId="defaultdb" cached="true">  
    <Publication Id="48" cached="true">
        <Item typeMapping="Page" storageId="fileRoot" cached="false" />
        <Item typeMapping="Binary" storageId="fileRoot" cached="false" />       
        <Item typeMapping="Metadata" storageId="defaultdb" cached="true" />             
    </Publication>

And a combination of the two. None of these appear to work.

Rogier has suggested that the problem lies with XPM. Is he correct? Does anyone have an XPM-enabled site that doesn't generate these warnings, and if so, how is it configured?

2

The answer from SDL support about this (R&D), is to disable the object cache in the cd_storage_conf.xml if XPM is enabled. XPM seems to force disabling object cache anyway. When enabled, the logging seems to be wrong. In a newer version of Tridion (SDL Web) will this logging issue be fixed...

The deployer doesn't seem to matter in this context. The object cache can be true without any extra logging and doesn't interfere this way with other (non-XPM) publications.

2

Essentially, having XPM on a website lowers the amount of caching done of componentlinks. There's nothing you can do about it. This, as far as i know, has always been the case since XPM was introduced.

The probably cause for this is that component links are cached very aggressively (up to being stale for 24h the last time i have had a look), which might be problematic for XPM's purpose.

  • I think it's important to separate preview behaviour from normal behaviour. I get it that preview bypasses the normal methods of deployment etc. The question is specifically about non-preview use of the site. (Do I need to make that explicit?) The XPM stuff needs to be there, but IMO should not interfere with normal use. – Dominic Cronin May 12 '15 at 7:40
  • No argument there really - it should not be different. – Rogier Oudshoorn May 14 '15 at 7:49
2

Please add the attribute cached="true" to the element.

By default the caching is not inherited from the top level (ItemTypes element) and and if cached attribute is not specified it is set to disabled, so in Publication 48 you now have caching disabled.

  • We have added cached="true" to the Publication element. This doesn't appear to solve the problem. – Dominic Cronin Jan 5 '16 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.