2

I have SmartTarget regions on a number of pages that are now XPM enabled, and I am not able to select them. When I click on the page's 'Properties border button' I also don't get a section in the pop-up for 'Targeted regions' (per the documentation). So it looks like XPM just isn't recognizing the regions.

I feel like I have trawled over the documentation, but am not seeing it... is there some mark-up I need to place around the ' tags in my template.

We are running 2013 SP1, ST 2014 SP1, CWA on the delivery side.

Thanks in advance.

Daniel

  • Are you using the SmartTarget TBBs as well as the "Enable inline editing for Page" TBB? And does the inline editing one come before "Apply SmartTarget Settings" in your template? – Peter Kjaer May 27 '15 at 12:29
  • Apply SmartTarget Settings comes first, then the DWT where I usually manually add the <tcdl:region... etc. then 'Enable inline... – Daniel May 27 '15 at 13:03
  • 1
    That won't work. The order should be DWT -> Inline editing -> SmartTarget TBBs. – Peter Kjaer May 27 '15 at 13:16
5

Many thanks to Peter Kjaer who has now cleared two SmartTarget road blocks for me in as many weeks! I have the XPM/ST integration now working, with the correct html marrkup. The final order was:

  1. DWT (with <tcdl region>)
  2. Enable inline editing for Page (TBB)
  3. Add SmartTarget Query
  4. Add Promotions
  5. Apply SmartTarget Settings

I will now be experimenting with having some conditional ST regions on a page, based on metadata (I have this in 2011), and will determine how I can avoid needing 3 and 4 so that the PT won't fail when the <tcdl:region>s are not on the page!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.