I have set up a fresh DXA website, and also installed the search module. I can publish all pages of the DXA website (nothing is customized ,this is a fresh install), and all my pages get indexed in solr.

However, one page consistently fails to publish, due to the following solr error

2015-05-29 14:56:56,330 ERROR DeployPipelineExecutor - Original stack trace for transaction: tcm:0-815149-66560
com.tridion.deployer.ProcessingException: Commit failed for transaction: tcm:0-815149-66560
at    com.tridion.deployer.phases.CommitPhase.handleFailure(CommitPhase.java:103) ~[cd_deployer.jar:na]
at com.tridion.deployer.phases.CommitPhase.execute(CommitPhase.java:87) ~[cd_deployer.jar:na]
at com.tridion.deployer.phases.DeployPipelineExecutor.runMainExecutePhase(DeployPipelineExecutor.java:198) [cd_deployer.jar:na]
at com.tridion.deployer.phases.DeployPipelineExecutor.doExecute(DeployPipelineExecutor.java:100) [cd_deployer.jar:na]
at com.tridion.deployer.phases.DeployPipelineExecutor.execute(DeployPipelineExecutor.java:64) [cd_deployer.jar:na]
at com.tridion.deployer.TransactionManager.handleDeployPackage(TransactionManager.java:82) [cd_deployer.jar:na]
at com.tridion.deployer.queue.QueueLocationHandler$1.run(QueueLocationHandler.java:180) [cd_deployer.jar:na]
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [na:1.7.0_60]
at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.7.0_60]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_60]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_60]
at java.lang.Thread.run(Unknown Source) [na:1.7.0_60]
Caused by: com.tridion.deployer.ProcessingException: Unable to commit transactions
at com.tridion.deployer.phases.AbstractStorageStep.commitTransaction(AbstractStorageStep.java:34) ~[cd_deployer.jar:na]
at com.tridion.deployer.phases.CommitPhase.execute(CommitPhase.java:77) ~[cd_deployer.jar:na]
... 10 common frames omitted
Caused by: com.tridion.broker.StorageException: Commit failed for transaction tcm:0-815149-66560 because of lazy loading error
at com.tridion.storage.StorageManagerFactory.commitTransaction(StorageManagerFactory.java:358) ~[cd_datalayer.jar:na]
at com.tridion.deployer.phases.AbstractStorageStep.commitTransaction(AbstractStorageStep.java:32) ~[cd_deployer.jar:na]
... 11 common frames omitted
Caused by: org.apache.solr.client.solrj.impl.HttpSolrServer$RemoteSolrException: lazy loading error
at org.apache.solr.client.solrj.impl.HttpSolrServer.executeMethod(HttpSolrServer.java:554) ~[solr-solrj-4.9.1.jar:4.9.1 1625909 - mike - 2014-09-18 04:09:05]
at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:210) ~[solr-solrj-4.9.1.jar:4.9.1 1625909 - mike - 2014-09-18 04:09:05]
at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:206) ~[solr-solrj-4.9.1.jar:4.9.1 1625909 - mike - 2014-09-18 04:09:05]
at org.apache.solr.client.solrj.request.AbstractUpdateRequest.process(AbstractUpdateRequest.java:124) ~[solr-solrj-4.9.1.jar:4.9.1 1625909 - mike - 2014-09-18 04:09:05]
at org.si4t.solr.SolrIndexDispatcher.addBinaries(SolrIndexDispatcher.java:184) ~[si4t-solr.jar:na]
at org.si4t.solr.SolrIndexer.commitAddBinariesToSolr(SolrIndexer.java:384) ~[si4t-solr.jar:na]
at org.si4t.solr.SolrIndexer.commit(SolrIndexer.java:309) ~[si4t-solr.jar:na]
at com.tridion.storage.si4t.SearchIndexProcessor.triggerIndexing(SearchIndexProcessor.java:274) ~[si4t.jar:na]
at com.tridion.storage.si4t.JPASearchDAOFactory.commitTransaction(JPASearchDAOFactory.java:189) ~[si4t.jar:na]
at com.tridion.storage.StorageManagerFactory.commitTransaction(StorageManagerFactory.java:354) ~[cd_datalayer.jar:na]
... 12 common frames omitted

The cause of this issue is something within solr:

 org.apache.solr.client.solrj.impl.HttpSolrServer$RemoteSolrException: lazy loading error

This error only occurs with the downloads page (further-information/downloads.html)

Anyone has an idea where i should look to fix this problem ?

up vote 5 down vote accepted

The downloads page contains PDF multimedia components, so I suspect this is the issue. When setting up Solr to index PDFs there are a lot of additional configuration settings and dependent libraries to add in. Double check your configuration related to binaries in the DXA docs, in particular for step 8. that the path to the binary extraction libraries (contrib/extraction/lib) matches that of your Solr installation.

  • This was the problem indeed - in my solrconfig.xml, the path to <lib dir="../contrib/extraction/lib" regex=".*\.jar" /> was incorrect. After fixing this, all worked fine – Harald Hoffelinck Jun 1 '15 at 8:08

I've seen this error before. I could be that the SI4T solr schema has a field with an invalid solr field type. You need to change it to string.

Regardless, check your SOLR logs. There should be more info on the root cause in there.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.