1

We have recently upgraded the CWA Application to 2011 SP1. So, as per the documentation, replaced the existing jars and replaced with cd_tdf.jar and cd_cwa.jars.

Changed the class value in cd_deployer_conf.xml with Deploy attribute from com.tridion.profserv.deployer.MetaDataProcessor to com.tridion.deployer.Processor.

Now, publish to Broker DB gets success, but the values in Custom Meta is not getting updated correctly. The fields like components, component_templates and others are getting removed.

Can you please help me here?

Thanks, Anusha

2

I understand CWA previously used the Custom Metadata Processor, which adds additional details the the CUSTOM_META table, partly based on XML snippets in your Component Templates.

Per the documentation, this has been deprecated, but can be enabled on the latest version (see the doc link), specifically:

The metadata processor, which was originally added as a custom Processor in the Content Deployer, is no longer a part of CWA. If you want to continue to use it, you must use the Professional Service TDF module. Even if you use the TDF module, you can no longer use the URLNormalisation setting in the cd_tdf_conf.xml configuration file: you must set its Enabled attribute to false, or remove it altogether

1
  • thanks.. We are still using the Professional Service TDF Module and then it works :)
    – user1563
    Jun 11 '15 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.