7

I'm following a suggestion from Dominic Cronin on setting up multiple host headers to help demonstrating different users on the same CMS, but I'm stuck at the login pop-up.

  1. As an administrator, I added the following to: C:\Windows\System32\drivers\etc\hosts and saved the changes.

    127.0.0.1 authors.tridion.local
    127.0.0.1 admin.tridion.local

  2. In the Site Bindings for SDL Tridion 2011 (my CMS installation) in IIS 7.5, I have:

    For authors:

    • Type: http
    • IP address: All Unssigned (i.e. "*")
    • Port: 80
    • Host name: authors.tridion.local

    For admins:

    • Type: http
    • IP address: All Unssigned (i.e. "*")
    • Port: 80
    • Host name: admin.tridion.local

    (tried other ports, but 80 works fine for multiple headers)

When attempting to visit http://authors.tridion.local or http://admin.tridion.local in Chrome, I'm prompted to log in (so the host and IIS setup seems to be partially working), but entering a valid user name and password won't get me past the login pop-up.

Cancelling the login pop-up gives me the IIS error:

HTTP Error 401.2 - Unauthorized
You are not authorized to view this page due to invalid authentication headers.

Additional info:

  • Application pool for Site SDL Tridion 2011 is SDL Tridion 2011 with physical path set to C:\Program Files(x86)\Tridion\web. This application pool is set to .NET v4.0 as Integrated for pipeline mode.
  • When attempting to log in to one of these additional urls, my already logged in administrator (on http://localhost), will see authorization errors such as /WebUI/Models/TCM54/Services/General.svc/GetItem failed to execute. STATUS (500): System.ServiceModel.ServiceActivationException.

I'm thinking I'm missing something with the ports (since updated to separate ports), Windows folder permissions, or an appropriate restart. How do I set up separate urls for different users on a Tridion CMS isntance/VM?

Update 1:

  • I disabled LoopBackChecks with regedit and restarted the VM (thanks, Chris). I can at least get past the login pop-ups to see most of the CME in Chrome and IE (after changing IE's security level).
  • I tried updating the WebRoot's web.config based on Dominic's post, but changes to multiport/multihostname under appSettings, httpModules, modules, and serviceHostingEnvironment were not needed.

Update 2 (part of the solution):

By default, for .NET 4.0, multiple headers for WCF sites in IIS is disabled.

Adding multipleSiteBindingsEnabled="true" to serviceHostingEnvironment now lets me browse each url as different users.

<system.serviceModel>
<serviceHostingEnvironment
    aspNetCompatibilityEnabled="true"
    multipleSiteBindingsEnabled="true">
  • 1
    Was you environment working correctly before adding the hostnames? on say localhost? Is it expecting a domain as part of the login? – Chris Morgan May 6 '13 at 17:43
  • Yes, localhost let me log in as the current user (Windows username/password). I was able to provide either the user directly, and I believe .\username worked as well to automatically select the domain. – Alvin Reyes May 6 '13 at 20:10
  • I'm wondering if a "switch user" GUI extension might be easier to apply across CMS's--I'm only trying this for demos and explanations involving a dev VM and multiple users. It doesn't have to be a multihost/port setup. :-D – Alvin Reyes May 6 '13 at 20:12
  • That is a good idea - I think the multihost/port approach could cause confusion to less technical editors. I can already hear "Why are there two different Tridion's?" :) – Chris Morgan May 6 '13 at 20:53
  • Why did you change from port 80? You can have multiple sites running on the same port as long as the have different host header mappings. – Dominic Cronin May 6 '13 at 22:20
7

I have had issues with than in the past. Something to do with LoopBackChecks. I disabled it by following http://support.microsoft.com/kb/896861

Also check out Installation issue with SDL Tridion 2013 & SDL Web 8 CME not loading all items properly

  • Ok, I'm part way there, after disabling LoopBackChecks and restarting, I am able to enter the passwords for the separate urls. I'm still getting /WebUI/Models/TCM54/Services/General.svc/GetUserSettings failed to execute. STATUS (500): System.ServiceModel.ServiceActivationException and the username doesn't show on the SDL Tridion tab (i.e. "Welcome, ."). I have Windows Authentication set for the IIS Tridion CMS site like Vivek has in the other TRex question. With Windows Auth, should my logged in user match? I get the error regardless if the user matches. – Alvin Reyes May 6 '13 at 18:24
  • Use fiddler to check the full path and credentials supplied to /WebUI/Models/TCM54/Services/General.svc/GetUserSettings. Sounds like credentials are not making it on the service call – Chris Morgan May 6 '13 at 18:32
  • Looks like it. Fiddler shows a "500" for GetUserSettings when using Chrome, but interestingly IE stops completely with a 401 Unauthorized (and gets "stuck" at the loading .gif). I'll try a bit more and maybe research this separately or start another question. – Alvin Reyes May 6 '13 at 18:53
  • For IE not loading, I didn't have the sites set to trusted or local intranet. I updated the question with more info. – Alvin Reyes May 6 '13 at 19:49
  • Thanks Chris. This worked, I was just missing an additional attribute for multipleSiteBindingsEnabled set to true. – Alvin Reyes May 7 '13 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.