0

We have recently change and register in the GAC a new version of the dlls that contain several Common Functions to be used in the templates for a Tridion 2011 SP1. Since this new registration we keep receiving the following error when trying to previewing or publishing our pages.

Error interno: Internal error on compiling JScript: Variable 'Component' has not been declared


Content Manager StackTrace:

Tridion.ContentManager.Templating.Expression.JScriptEvaluator.BuildJScriptAssembly(IList`1) Tridion.ContentManager.Templating.Expression.JScriptEvaluator..ctor(Package) Tridion.ContentManager.Templating.Expression.ExpressionEvaluator..ctor(Package) Tridion.ContentManager.Templating.Package..ctor(Engine) Tridion.ContentManager.Templating.Package..ctor(Engine,IdentifiableObject) Tridion.ContentManager.Templating.Engine.TransformItem(Template,IdentifiableObject) Tridion.ContentManager.Templating.TemplatingRenderer.Render(ResolvedItem,PublishInstruction,PublicationTarget,RenderedItem,RenderContext) Tridion.ContentManager.Publishing.Rendering.RenderEngine.Render(ResolvedItem,PublishInstruction,PublicationTarget,RenderContext) Tridion.ContentManager.Publishing.Rendering.RenderEngine.Render(IdentifiableObject,Template,PublishInstruction,PublicationTarget,RenderContext) Tridion.ContentManager.Publishing.Rendering.ComWrapper.RenderEngineFacade.RenderItemWithTemplate(IdentifiableObject,Template,PublishInstruction,PublicationTarget,RenderContext) Tridion.ContentManager.Publishing.Rendering.ComWrapper.RenderEngineFacade.RenderItemWithTemplate(IdentifiableObject,Template,String) Tridion.ContentManager.Publishing.Rendering.ComWrapper.RenderEngineFacade.RenderComponentPresenation(UserContext,String,String,String) UtilitiesPublish.RenderComponentPresentation ComponentPresentation.Render Component.Render Request.Render

Has any of you seen this error before?

Thanks!

  • 2
    DId you reboot after updating the dll? – Andrey Marchuk Jun 11 '15 at 9:45
  • Yes...or at least the team in charge of doing it said they did! – Emma Varona Jun 11 '15 at 9:45
1

Since this happened after GACing new DLLs, it is more than likely that it is a GAC issue. To get the updated DLLs to replace the existing one in GAC, you need to remove the old one first. You should uninstall the previous DLLs and then install the new DLLs in the GAC. This should resolve the issue if it is related to GAC.

Also, can you try using the dll in any of your application by direct reference to ensure at least the functionality is not broken.

Also, on a side note try to avoid using GAC unless mandatory (like for custom resolver) since it involves hassles. There are better ways of sharing like NUGET which is way easier to use.

| improve this answer | |
-4

This is now solved...It was an issue regarding some of the functions.

Thanks!

| improve this answer | |
  • 1
    Would be nice if you can edit this answer and provide some more details about hos you solved the issue, that is useful for other who might encounter the same. – Bart Koopman Aug 13 '15 at 11:38
  • What we did to solve this issue was to review some of our Common Functions that were receiving 'Component' parameters and therefore we were receiving the error explained previously. We changed the functions and it is now working ok. – Emma Varona Aug 31 '15 at 7:34
  • 3
    It would be nice if you edited your answer and put the info in there, that makes it a lot more visbible than placing it here in a comment as a response on mine. This site is intended for the entire community and somebody in the future might encounter a similar issue, and it would be nice if they find your answer with all details and see that it is an accepted answer with possibly helpful information for them – Bart Koopman Aug 31 '15 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.