7

When I use the "Update Preview" feature in Experience Manager I get this error in the XPM GUI:

Unable to update or add Binaries using OData Service. An error occurred while processing this request. BadRequest

enter image description here

In the website and CD Web Service (aka Preview service) logs I do not see any related errors.

What could possibly be amiss?

  • Hi Jan, if you already knew the answer to your question (since your question and answer are posted at the exact same time), then what is the need to post a question on stack exchange? – Vipin Kothari Jun 15 '15 at 14:04
  • 3
    @Vipin See what Stackoverflow writes about self answereing: stackoverflow.com/help/self-answer . Also, I should have posted the question when I ran into the issue and realized the issue is not posted on Tridion.Stackexchange. I did post it after the fact to document it for others, that works cause you found the information in less than 30 minutes ;). It will also come in handy next time I run into the same issue. Furthermore I only have one asnwer to the question, if you have another view you can add another answer. – Jan H Jun 15 '15 at 14:17
9

This error occurs when the message size limits in the CD web service configuration are too strict.

During XPMs fast track publishing process (part of the session preview mechanism) the CM cannot publish the binaries (i.e. images) on your site. Possibly one of the images on the page is too large to be published to the CD Web Service.

Check the web.config of the CD Web Service webapp (assuming the .NET version of the CD Web Service here). Try raising the maxReceivedMessageSize and maxBufferSize. Those parameters limit the size of the request when the CM tries to fast track publishes images to the session preview mechanism on the CD web service.

By default this limit is set to 2097152 (2MB) which might a bit too small when using nice big images like the example content in DXA.

<configuration>
    <system.serviceModel>
        <bindings>
            <webHttpBinding>
                <binding name="HttpBinding" maxReceivedMessageSize="524288000" maxBufferSize="524288000">

A similar problem can occur on the CD Deployer when you try to deploy a binary which is too big.

| improve this answer | |
  • Thanks for posting this Jan! I was actually facing similar issue with the fast track publishing and updating the message limit size fixed it for me :) – Robert Jin Jun 15 '15 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.