0

Everything works fine, but binary fields are not rendering when I click on the update preview button in XPM. Content on the Page is fine and updated also after editing.

I am getting a DirectoryNotFoundException exception in log files for all binary files on the Page.

Error Handling www.test.com/languagename/imagefolder/imagename_tcm444-555555.png ... System.IO.DirectoryNotFoundException (mscorlib) ... Could not find a part of the path 'F:\WWW\publishedcontentfolder\country\images\country\images\imagename_tcm444-555555_6e489499-f95a-4685-ae26-1cf9f44731ab.png'. ... at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

It is writing the country\image twice while requesting binary for update preview button click.

  • Have you set a maximum size for binary items for preview in the XPM session preview settings, and are the binaries you are requesting larger than that? – Bart Koopman Jun 19 '15 at 8:56
  • In the path I see: publiahedcontentfodler, is it correct? I guess, it should be publishedcontentfolder (two problems: a instead of s and ld swapped) – Hiren Kaku Jun 19 '15 at 22:08
  • @ Bart : I will check for the binary size and will let you know the result. @Hiren : That was typo and not the actual path . – Jitender sharma Jun 21 '15 at 10:15
  • What are the path and URL settings and images path and URL settings in the publication properties? – Jeroen Suurd Jul 25 '15 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.