0

While editing content in the rich text field using Rich Text editor pop up window (within XPM) - bold, italics and underline functionality is not working. Whereas these functionalities are working fine using Ribbon Toolbar buttons. It is also working fine if short cut keys (ctrl+b, ctrl+i, ctrl+u ) are used.

Any pointers will be appreciated.

  • By not working do you mean the rich text lacks styling? When you mention the rich text format area works with Ribbon Toolbar and shortcut keys, is that only in the Component form view? – Alvin Reyes Jul 1 '15 at 4:59
  • I mean rich text editor not working as expected in case of using rich text editor popup window (properties box) in XPM. In the rich text field, after selecting text to make it bold/italics/underline and then click respective button from the popup window nothing happens. – Nitin Chaurasia Jul 1 '15 at 5:13
  • That might be a bug especially if that field is configured to allow bold, italics, and underline. Also double check it just isn't styling that prevents displaying bold by saving changes and checking the Component's form view. If it's really not making the change, log a ticket with SDL Support. – Alvin Reyes Jul 1 '15 at 11:28
  • @NitinChaurasia, can you tag the question with the product version in use, please include Service Pack and Hotfix Rollup versions if applicable, thanks. – Elena Serghie Jul 1 '15 at 13:25
  • It works for me. On popup as well as from the ribbon bar. So, please check if you are seeing some errors on the DOM – Vipin Kothari Jul 1 '15 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.