5

Scenario:

I have a bundle which has 4 pages, A,B,C and D. Out of these pages 2 are published (A and B) and 2 are new pages (not published any where). The bundle is being published to single target type associated with only one publication target.

When I select the bundle for publish, “Republish Only (Do Not Publish New Content)” option is selected and if I click "Show Items To Publish", I see Page A and B in the list of items to be published from the bundle which is a correct behavior.

Question:

Now, if I un-select the “Republish Only (Do Not Publish New Content)” option and subsequently click/check the "Show Items To Publish", the list is not getting updated and is still showing Page A and B. It does not include Page C and D which should have been included in "Show Items To Publish" since I had un-selected the “Republish Only (Do Not Publish New Content)”option. The Show Items to Publish list is not getting updated on select/un-select of “Republish Only (Do Not Publish New Content)” option no matter how many times I select or un-select the checkbox

If only I select a different target type and then click on "Show Items To Publish" the list gets updated and shows Page A,B,C and D.

Is anybody else facing the same issue with “Republish Only (Do Not Publish New Content)” option? Or is this a known issue? Is there a hotfix I am missing for this specific functionality?

We are using Tridion 2013 SP1. I have tested on all the browsers and see the same issue.

Edit 1:

I validated the publishes and it is working as expected and includes the Pages A,B,C and D. The problematic part seems to be the GUI since it is not showing the correct details and makes you think that the pages are not going to be part of the publish even when you uncheck the option. The only way to figure out what is published, is by opening the transaction details and finding list of items processed! I am planning to open a ticket with Tridion since it seems a bug

Edit 2:

I have raised a ticket with Tridion Support for the same. Alternatively, there are three possible ways of refreshing the list:

  1. As suggested by Alvin, using the "Refresh" button after select/unselect on “Republish Only (Do Not Publish New Content)” will refresh the list of items to be published

  2. Click on "Hide Items To Publish" and then "Show Items To Publish" button after select/unselect on “Republish Only (Do Not Publish New Content)”. This also refreshes the list of items to be published

  3. Change the target type or unselect and select the target type after select/unselect on “Republish Only (Do Not Publish New Content)” will also refresh the list of items to be published

  • Did you check if pages C and D are being published as expected when you uncheck "Republish Only"? It would be helpful to know if it's just an issue with the GUI or if the underlying functionality is affected as well. – Tanner Brine Jul 2 '15 at 21:14
  • Updated the question to include the details – Vipin Kothari Jul 2 '15 at 21:35
  • At least in Chrome and Firefox, toggling the Show Items or pressing the Refresh button at the bottom of the Show Items to Publish list seem to both update the list of pages in a Bundle correctly (Tridion 2013 SP1 setup, 7.1.0.66). Try the Refresh button but definitely run this by Support, maybe also checking for what the browser Console reports. – Alvin Reyes Jul 3 '15 at 4:56
  • Have you installed HR1? – Peter Kjaer Jul 3 '15 at 5:30
  • @PeterKjaer no we haven't installed HR1 – Vipin Kothari Jul 3 '15 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.