1

I built some tcdl tags for a component node and published it. I am able to see tcdl tags in Broker database for a component.

But Now when I am accessing the dynamic component content via Content Service API's, it is not fetching Content from component, instead it is showing tcdl tags only.I want to process the tcdl tags and get component content as a result.

Thanks in advance

  • Are we talking about your own, custom tags? If so, did you already follow all of the instructions listed in the following documentation section? docs.sdl.com/LiveContent/content/en-US/… – Peter Kjaer Jul 9 '15 at 11:55
  • 2
    Please add information on what you've done so far, as there's a lot you need to do. For instance: write TagHandlers and TagRenderers, create a TagBundle XML file, configured them in cd_deployer_conf.xml and cd_dynamic_conf.xml, change your Component Presentations to REL, etc. etc. – Peter Kjaer Jul 9 '15 at 12:20
  • Yes I have created custom tcdl tags and using Publication Target Language as 'REL'. As I am using default tcdl:componentPresentation tag so is there any need to define this tag. – SAnonymous Jul 9 '15 at 12:24
1

If you've created your tcdl tag handlers as discussed in the comments, then make sure you're fetching the component presentations using the ComponentPresentationAssembler not the Factory. The CP Factory does not do any TCDL processing.

The other thing could be that if you are using the Assembler class, use the item ID part of the TCM URI only (middle number) to get content, not the entire TCM URI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.