1

I have a DD4T website in Tridion 2013 where Site edit is also functional.

I am facing issue with getting the lock symbol for a component presentation added in couple of pages hence not able to edit it via XPM. The same presentation if added in any other page is working and having the lock symbol.

Not sure what is wrong with those two pages as the border is properly formed but no lock symbol is there. Any input for this please.

  • What color is the border? Are the other pages within the same session (same or different browser and/or user)? And are all pages published or at least have an updated session preview? – Alvin Reyes Jul 23 '15 at 17:03
  • Grey color. Even other components in those two pages has Update Preview and shows the lock but the lock is not there for that particular comp. Yes, other pages in same session and all browsers show the lock except these two. All pages are published. – manish Jul 23 '15 at 18:16
  • Ok, grey means not-editable at this time for the current user. Functionally the other reasons could be it is the same Component in different Publications (where it's localized and locked in one Publication) or it's not really the same Component. For example, if using Page Types, it's easy to create Component Presentations that look exactly the same. Check the tcm URLs and version history, looking specifically for minor versions suggesting the item really is locked (and by whom). – Alvin Reyes Jul 23 '15 at 18:54
  • I don't see the minor version in history(all are in xx.0) and also no lock is there for the comp. – manish Jul 23 '15 at 19:58
0

To get component lock icon with border, the component with experience manager tag should be embedded in any html tag (for e.g. div).

In your case, check the pages where you are getting the lock icon, your component rendering would have been inside some html tag.

Also, verify properties to enable experience manger at page and page template level, verify that.

| improve this answer | |
  • Yes, inside a div. The comp renders with same CT in all the pages - but in two of the pages lock is not there and other pages have the lock for the same comp presentation. – manish Jul 23 '15 at 3:07
  • Updated answer to include more details – Hiren Kaku Jul 23 '15 at 3:19
  • Is the problem that you can edit the component in XPM (and that should not be possible) or is the problem that it just doesn't show the lock symbol (as a styling issue)? – Bjørn van Dommelen Jul 23 '15 at 11:11
  • The same component shows lock in all other pages except two. I can edit them using Open in Form view option but no lock to edit via on browser. – manish Jul 23 '15 at 14:00
-1

Ok so the problem were couple of other comps in the page whose view was not correct w.r.t XPM as @Html.SiteEditComponentPresentation(Model) was not inside any div and this was causing the comps with correct views to loose their HTML.

| improve this answer | |
  • What extra information that you have shared? This was already given in the answer that I had provided. So I don't see any point of creating new answer. – Hiren Kaku Jul 24 '15 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.