So for reasons I won't go into, we recently had to re-configure our clients Tridion 2013 SP1 CM to use a new SQL Server.

After the usual planning and content freeze, it basically went like this:

  1. Backup old CM db & copy to new SQL Server.
  2. Restore backup onto new SQL Server.

On CM server itself:

  1. Stop all services, shutdown COM+ and stop IIS.
  2. Open Tridion Configuraiton snap-in and update the database section with new details. Save & close.
  3. Restart services and IIS.

We had a few initial MS DTC issues that stopped us from saving schemas for example, but these were overcome. It's when we turned the old SQL Server off that things got strange.

On first load of the CM in the browser we got an SQL connection error notification. Also, copying & pasting multiple components just wouldn't work - I traced this to the same SQL connection error being thrown by the Tridion Batch Processing Service.

When we turned back on the old CM SQL Server the error went away and multiple copy/paste worked!

There are other Tridon components installed (e.g. AM or TM) and my understanding is that the only db connection string is the one managed through the snap-in.

Is there a step I've missed from the above? Perhaps the Batch Processor "kept hold" of the old reference somehow?

  • Do you have OutboundEmail installed? Can you post the full error showing in the windows event log? Commented Aug 14, 2015 at 20:26

4 Answers 4


I usually follow following steps.

Login to SQL Server Management to restore the database

  1. Take backup and restore it.
  2. Open the Security\User folder of the new database
  3. take a screenshot of TCMDBUser mappings and Delete the TCMDBUser,
  4. Go to the master Security\Login folder
  5. Find the TCMDBUser and open it
  6. Select User Mapping; map this user to the new database with the appropriate access: db_datareader, db_datawriter, db_ddladmin, db_owner as per screenshot.
  7. Exit SQL Server Management

  8. Open Tridion Content Manager configuration console

  9. Select the Database Setting and change the database name to the new database name
  10. Save and exit the configuration console
  11. Restart IIS and COM+.
  • question what if mtsuser on the source system is named differently (ex. x-mtsuser) than what is named in the target system.. ? ie. <SOURCE> X-MTSUser <TARGET> MTSUSER ? Is the user MTSUser in play here at all? I have just restored and I am getting Login failed for user TCMDBUSER after following the (appreciative) detailed steps above. I am just trying to think what else would be different, I changed to have matching passwords (I think - in SSMS & MMC, is that only two places?) Commented Mar 30, 2018 at 17:51

AudienceManager and OutboundEmail rely on \%TRIDION_HOME%\config\OutboundEmail.xml This file also contains a database connection. Not sure this is what is happening in the case mentioned above though, perhaps the full stack trace may give more information.


Being unable to copy/paste multiple items definitely points to the Batch processor service.

In the past I've seen the same issue where the main Tridion.ContentManager.Config.xml file had an invalid user configured for the service after an environment move... This user was not changeable through the MMC snap-in. Perhaps there's a connection string lurking in there as well?

How about searching that file for the old server/dB name?

  • 1
    My guess is that there are additional parameters in T.CM.Config that need changes and these are not exposed in the MMC...
    – Nuno Linhares
    Commented Aug 17, 2015 at 11:25
  • ^ What I meant, but written more succinctly. I wrote my answer at about 2am :) Commented Aug 17, 2015 at 11:32

also would truncate the queue_consumers table, restart all tridion services, as well as, would run update statistics.

  • That would take you out of support, I'd think. Far better simply to shut down all your services before you take the backup. Failing that, ask support for help with cleaning up phantom queue consumers. Commented Dec 1, 2016 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.