3

I'm receiving the following error during the publishing of a component:

Deploying Failed:

Polling for notification for destination:
Ga52wnQ71S9sau5Tqoippg== has exceeded polling attempts 
for transaction: tcm:0-79304-66560

This seems to correspond with an error message from the cd_deployer.log on the CD server:

2015-08-19 11:46:29,550 ERROR DeployPipelineExecutor - Final attempt in Phase: Deployment Processing Phase failed for transaction: tcm:0-79304-66560
2015-08-19 11:46:29,550 ERROR DeployPipelineExecutor - Original stack trace for transaction: tcm:0-79304-66560
java.lang.OutOfMemoryError: Java heap space
    at java.util.Arrays.copyOf(Unknown Source) ~[na:1.7.0_45]
    at java.io.CharArrayWriter.write(Unknown Source) ~[na:1.7.0_45]
    at com.tridion.util.FileUtils.readEncodedFile(FileUtils.java:426) ~[cd_core.jar:na]
    at com.tridion.util.FileUtils.readEncodedFile(FileUtils.java:406) ~[cd_core.jar:na]
    at com.tridion.deployer.TCDLTransformer.readFileAsString(TCDLTransformer.java:159) ~[cd_deployer.jar:na]
    at com.tridion.deployer.TCDLTransformer.transform(TCDLTransformer.java:83) ~[cd_deployer.jar:na]
    at com.tridion.deployer.TransformProcessor.transformItem(TransformProcessor.java:185) ~[cd_deployer.jar:na]
    at com.tridion.deployer.modules.ComponentPresentationDeploy.processComponentPresentation(ComponentPresentationDeploy.java:123) ~[cd_deployer.jar:na]
    at com.tridion.deployer.modules.ComponentPresentationDeploy.processItem(ComponentPresentationDeploy.java:105) ~[cd_deployer.jar:na]
    at com.tridion.deployer.SectionVisitor.processSection(SectionVisitor.java:83) ~[cd_deployer.jar:na]
    at com.tridion.deployer.SectionVisitor.process(SectionVisitor.java:60) ~[cd_deployer.jar:na]
    at com.tridion.deployer.Processor.process(Processor.java:109) ~[cd_deployer.jar:na]
    at com.tridion.deployer.workers.ProcessorWorker.doWork(ProcessorWorker.java:77) ~[cd_deployer.jar:na]
    at com.tridion.deployer.phases.ProcessingPhase.execute(ProcessingPhase.java:73) ~[cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.runMainExecutePhase(DeployPipelineExecutor.java:198) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.doExecute(DeployPipelineExecutor.java:100) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.execute(DeployPipelineExecutor.java:64) [cd_deployer.jar:na]
    at com.tridion.deployer.TransactionManager.handleDeployPackage(TransactionManager.java:82) [cd_deployer.jar:na]
    at com.tridion.deployer.queue.QueueLocationHandler$1.run(QueueLocationHandler.java:180) [cd_deployer.jar:na]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [na:1.7.0_45]
    at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.7.0_45]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_45]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_45]
    at java.lang.Thread.run(Unknown Source) [na:1.7.0_45]

When I run "java -XX:+PrintFlagsFinal", the max heap size is set to 2GB:

uintx MaxHeapSize                              := 2013265920      {product}

Any ideas on what could be causing the heap error (or suggestions on how to resolve it?)

3

As you probably expect, the CM side error is a 'knock-on' effect of the deployer error. It simply tried to contact the deployer too many times after it died and gave up.

As for deployer error, clearly you have run out of heap space for some reason. I would initially look at the configured threads and window size for the deployer (i.e. are you trying to handle too much at once?) or possibly for any unusual (large?) publish jobs (root structure groups being published perhaps), though I'd say it's far more likely the former.

3

As David mentions, the CM error is just a symptom of the Deployer error.

The Deployer error could be:

  • Large volume of content (publishing root SGs, as David mentioned)
  • Large size of content (saw a similar error when a single component rendered at 200+ MB)
  • A Deployer bug

Key questions:

  • Does this error occur for all Publish jobs?
  • Does this error occur every time for the same content?
  • How long was the Deployer actively handling this job before the error occurred?
  • If you bump the Deployer log level to DEBUG or TRACE, anything interesting come up?
  • Are there any Deployer extensions installed? Does the issue reproduce without them?
  • hi Andy, can you also let us know the version of this deployer? is it on tomcat, etc? do you already have a minimum and maximum memory allocated when starting up the deployer process? If you are using tomcat, for example, I often see that I need to explicitly set a -Xms and -Xmx to overcome that type of error you are seeing. – Roli Aug 20 '15 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.