5

While importing contacts in Audience manager. There is a options for field separator. Like here you can choose semicolon or comma. But while exporting contacts we do not get any pop up or previous setting why? Am I missed some entry in any configuration file of tridion. Because in US countries field separator is comma but in european countries field separator is semi colon. Please guide me on this. Any answer or solution will be really very helpful.

2

Exporting Contact will always give you a comma-separated values (CSV) file. There are no options there because frankly we felt that would be needlessly annoying (whereas import needed to support different formats from other systems).

There is no difference in the format exported depending on the country. That is likely the result of something they do to the file afterwards.

| improve this answer | |
  • Peter, In european countries .csv file uses the semicolon by default. So the Tridion system should take the regional setting of the system. Because after exporting contacts from audience manager they got actually comma separated file but according to their region they should get semicolon separated .csv file. After exporting contacts they did'nt able to open that file. File looks ugly for them. – Ankit Sep 1 '15 at 12:42
  • 1
    The defining element of a CSV file is that it is "comma separated values". Separating them by semi-colon would make it a different kind of file. The file can be opened in any text editor and a lot of other editors too. The reason we chose CSV is that it is one of the most well supported standards and so will be supported by the widest range of systems and products. By the way, I'm European too and the notion that the whole continent would somehow take offense to a comma-separated file is very strange to me :) – Peter Kjaer Sep 1 '15 at 13:05
  • 2
    I'm guessing your users are opening the files in Excel, which is the problem. Microsoft Excel interprets CSV files based on the regional setting 'list separator' and only allows you to change that behavior when you do an Import instead of simply opening the file. That is rather bizarre, but there is no way to change that while maintaining the standard CSV format. – Peter Kjaer Sep 1 '15 at 13:48
  • That is a useful information Peter. Thanks. Ankit, you can change the regional settings and make sure to change both Separator as well as Decimal symbol as explained here akbaraji.wordpress.com/2012/05/29/… – Saurabh Mehndiratta Sep 2 '15 at 5:09
  • 1
    The specification of the exporter is not "produce a file that any Excel program likes to eat" but to "produce a valid comma separated file for importing in another program". If you want a different format than the one produced write a small script to convert it into a different format. – Bjørn van Dommelen Sep 4 '15 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.