1

I am facing some fundamental issue with configuring logging on the Content Manager server. SDL-2011 SP1

Issue:

When i put the log.level="WARN" its creating the log files but with no data into it Its working fine it i change the log.level="ALL" or "INFO". I cant make it "ALL" or "INFO" on production environment :(

What i tried till now:

I have configure the logging and set the level to "WARN", in CMS i have stopped the Transport service so when i am publishing something i am expected some error logs to be generated in transport.log file but not the case its showing a 0KB file.

Hope i am able to explain my problem :) Looking forward for some expert touch :)

  • hi all still haven't got any solution - So let me explain the issue here When i put the log.level="WARN" its creating the log files but with no data it creates a 0 Kb file but if i change the log.level="ALL" or "INFO" its work fine . I cant make it "ALL" or "INFO" on production environment :( – user36299 Sep 9 '15 at 13:03
2

The transport log logs events that occur during transportation by the transport service itself. By having the transport service stopped, there is simply nothing running to update the log. Your transport packages will probably just wait to be picked up when a transport service comes back up again or may fail with a timeout after a while.

If you're trying to detect the unavailability of a service, I suggest that you look into the Tridion monitoring service, which will watch other Tridion services for you and raise SNMP notifications etc. See Monitoring SDL Tridion Processes in the online documentation for more information.

  • Hi David, Thank you for your reply, yes I am exactly looking to detect the unavailability of a service, and for that I am trying to implement Tridion monitoring service. Please correct me if I am wrong here logback.xml is directly related to cd_monitor_conf.xml? So in cd_monitor_conf.xml we define which service needs to be monitored and in logback.xml we defined which information needs to be recorded (please correct me if I am wrong here) so the problem here is if I set log.level=“WARN” it logs info in “cd_monitoring.log “ but if I set the Log.Level=”INFO” it starts generating info. – user36299 Sep 4 '15 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.