3

On our staging server, we have a website with name: http://staging.###solutions.com. Inside this website, we have created a number of Virtual directories for each of the different locale/Country such as: cz_cz for Czech Republic, nz_nz for New Zealand.

The issue we are facing is when viewed in browser, the internal Links aren't resolving correctly. For example, as seen below, in the Link the Path is actually correct except that the Locale directory [cz_cz or nz_nz] is missing.

The URL should have been: ...solutions.com/cz_cz/Brand/Brandlist.aspx and not like: ...solutions.com/Brand/BrandList.aspx
enter image description here

2

Try adding below settings in cd_link_conf.xml file ( the Dynamic Link Resolver configuration file ):

<Publications>

<Publication Id="100"> <!-- set id to your Publications ID -->
<!-- Set the Domain to complete Virtual Path of Website in IIS -->
<!-- And Set the Path to "/" as below -->
<Host Domain="staging.###solutions.com/cz_cz" Port="80" Path="/" />
<Linking ComponentAnchors="false" AddComponentLinkInfo="false" />
</Publication>

</Publications>

Also, you may try removing the virtual path from Domain attribute and specify the virtual directory in Path attribute as Path="/cz_cz"

<Host Domain="staging.###solutions.com" Port="80" Path="/cz_cz" />

Either of the settings should work.

  • Where can I find this file: cd_link_conf ? – S thangley Sep 8 '15 at 14:52
  • 1
    check the bin/config/ folder of the site – R.C Sep 8 '15 at 15:02
  • Thanks R.C. This solution worked perfectly! Can you please point me to the Documents where I can read more on this configuration file ? – S thangley Sep 8 '15 at 16:56
  • Check this Link: media.leidenuniv.nl/legacy/… – R.C Sep 9 '15 at 9:01
1

Your issue is that Dynamic Linking does not know that you are hosting the sites (publications) under sub folders.

You can resolve this by doing one of the following:

  • Updating your dynamic linking configuration, as per R.C.'s answer
  • Changing you publication's properties in Tridion to include the subfolder name in the Publication URL and republish your content

Check your images too... Depending on your configuration, If you have not set your Images URL accordingly in publication properties then you may not be referencing the correct images. Dynamic Linking may not help here.

  • 1
    Yes, I checked my Publication's property and the Images URL is set there. I doubt I can change the Publication URL as the setup is different on Live – S thangley Sep 8 '15 at 14:59
  • Thanks David. Your answer did helped me understand the issue at hand. – S thangley Sep 8 '15 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.