5

What is the recommended pre-requisite for SDL Web 8:

  1. Server Requirement - Basic DTAP works or do we need an additional License server?
  2. Supported DBMS & versions
  3. Supported OS for CM and CD
  4. Supported JRE/JDK
  5. Supported Browsers - MS Edge?
  6. Minimum Hardware Requirement
3
  • This is a good question, but I think you're better off waiting until Web 8 is officially released. I know it's imminent, but you never know what might change. I'd hate to tell you something was supported only for it to be dropped last minute. Oct 26 '15 at 11:52
  • 1
    Thans David; Just put this question to help community in preparing ahead of schedule as I have already seen some definitive answers for SDL Web 8 in TREX Oct 26 '15 at 11:54
  • I get that... And on release I would be happy to put info here as an answer, but until then (particularly as an SDL employee) I wouldn't want to / be able to Oct 26 '15 at 11:56
6

As David says, we can always change pre-reqs before the release, and actually - the documentation is part of the release. So, wait a few more weeks.

However, I can say a few things about it already that will probably not change.

  1. Server Requirement - Basic DTAP works or do we need an additional License server?
    • No changes done to licensing in this release, this will come later.
  2. Supported DBMS & versions
    • Look at our previous history of releases, and you'll find the pattern. Latest 2 major release of the databases. Oh, and we've added SQL Azure and AWS SQL RDS.
  3. Supported OS for CM and CD
    • Look at our previous history of releases, and you'll find the pattern. Latest 2 major release of the Operating Systems. With the new microservices architecture we won't care which OS you use for the Web Application, only for our Services.
  4. Supported JRE/JDK
    • Java 8. Java 7 is not supported by Oracle anymore.
  5. Supported Browsers - MS Edge?
    • We've tried our best, but we simply couldn't get Edge to work with Tridion. There's quite a few standard dependencies that Microsoft is still working on that we would need to run Tridion, so until further notice (and Edge updates) we will not support CME or XPM on Edge.
  6. Minimum Hardware Requirement
    • Nothing to put here, our objective is to always provide equivalent performance on equivalent hardware. We will publish our requirements in the docs.
2

Since the Web 8 has released now - the various prerequisite are listed on the official documentation portal HERE

You can further refer my blog post of a prerequisite cheat-sheet HERE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.