I am trying to implement the read only field in Tridion 2013 SP1 using GUI Extension. I have followed all the steps provided in this article

But it is not working. Hope I have missed something at the last step -

Here is the entry for for my extension in System.config file -

<editor name="Readonly">

May I have to add any thing else into the System.config ? Please suggest.

  • you need to check with the creator if that actually works, you can also checkout the Field Behavior Injection extension that was created a couple of years back, It never was completely finished, but we did have stuff like readonly working if I remember correctly. Commented Nov 12, 2015 at 11:11
  • Please open the JavaScript console and see what errors are showing up. Most likely something in the .js of the extension is not working. When I wrote the article it did work on my Tridion 2011 system, but I noticed that some 2011 extensions need a small update in the JS file to work with 2013. However, I forgot what that small adjustment was....
    – robrtc
    Commented Nov 12, 2015 at 11:38

2 Answers 2


Did you try it with the comment from Mark Sizer at the bottom of the article?

Also - this would be needed for Production systems. For Dev, I usually disable the GUI minification feature, to make debugging extensions easier...

var addJquery = function ()
// … jQuery here …
//YM: to avoid conflict with the Outbound Email extension, we define a new shorthand for jQuery
window.$j = jQuery.noConflict(true);
  • As it is the POC server, I have disabled the GUI minification feature Commented Nov 13, 2015 at 15:21

Did you update the modification number in the system.config file?

When you say

not working

what do you mean?

[ ] Crashes your computer,

[ ] Tridion doesn't load > nothing,

[ ] Tridion doesn't load > partially renders,

[ ] gives a JS error in the JS Console,

[ ] Writes something specific to the logs.

The more information you can provide with regards what you have looked at / confirmed will help us help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.