3

I am compiling the DXA 1.2 standard project with the help of mvn command but getting this error.

why project is not able to download all dd4t 2.0.2 jar files from the maven repository?

[ERROR] Failed to execute goal on project dxa-tridion-provider: Could not resolve dependencies for project com.sdl.dxa:dxa-tridion-provider:jar:1.3-SNAPSHOT: The following artifacts could not be resolved: org.dd4t:dd4t-api:jar:2.0.2-DXA, org.dd4t:dd4t-core:jar:2.0.2-DXA, org.dd4t:dd4t-databind:jar:2.0.2-DXA, org.dd4t:dd4t-providers:jar:2.0.2-DXA: Failure to find org.dd4t:dd4t-api:jar:2.0.2-DXA in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]

2

DXA 1.2 is using a custom build of DD4T since we needed the latest changes which at that time we not released into Maven central yet.

You can find the 2.0.2-DXA jars in the DXA download (https://community.sdl.com/developers/tridion_developer/m/mediagallery/1241) so you can place them in a local Maven repository.

We are currently busy releasing all the DXA 1.2 jars to Maven Central, but if I'm correct that will not include the custom DD4T build. So you will still have to manually solve that via a local Maven repo.

We are planning to release DXA 1.3 around x-mas, if all goes well by then all the SDL Web 8 jars, DXA and DD4T jars will all be available in Maven Central (once DD4T 2.0 is out of beta and SDL Web 8 is released).

| improve this answer | |
  • Does it mean DXA 1.3 would require SDL Web 8 or would it maintain backwards compatibility with SDL Tridion 2013 SP1? – Husain Zahid Nov 26 '15 at 13:41
  • @hzahid DXA 1.3 will be released for both 2013 SP1 HR1 and Web 8, but the Content Delivery client jars of Web 8 will be the only ones that go into Maven once Web 8 is released. – Bart Koopman Nov 26 '15 at 13:46
1

The DXA 1.2 JAVA uses a custom build of DD4T as the 2.0.2-DXA version inlcuding org.dd4t:dd4t-api:2.0.2-DXA which is mentioned in your error message. This custom DD4T build is not released in Maven Central.

DD4T 2.0 for JAVA is released today in Maven Central as DD4T 2.0.2. Perhaps DXA 1.2 JAVA is compatible with the officual DD4T 2.0.2 already.

Also see the dd4t site and the Trivident blog.

| improve this answer | |
0

As of yesterday, DD4T 2.0 for Java is taken out of beta status and the release has been uploaded to Maven Central.

This release should be compatible with the custom build, but please don't take my word for it; the DXA team will announce compatibility for each DXA version. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.