6

I'm trying to implement XPM & I think I'm running into the z-index issue described here. The symptom is that I don't get any borders around the HTML block in question, but I have valid XPM comments being generated. I checked & the block has a z-index higher than 1.

I tried to implement the Javascript fix in the article, but it didn't help. Has anyone tried that fix with Tridion 2011? Has this issue been resolved in Tridion 2013?

  • 1
    Do any components show borders in XPM and does the schema have the fields enabled for inline editing as well? – Alvin Reyes May 18 '13 at 0:13
  • 1
    The article you link to describes a fix for SiteEdit 2009, which is very different from Experience Manager. Which one are you using? It also helps if you show the relevant fragment of your HTML and CSS. – Frank van Puffelen May 18 '13 at 12:06
  • Thanks for the responses. Other components on that page are showing borders. This is the only component that I've tried to enable in XPM that has z-index >0. Based upon Frank's comment I think I'm going to follow up with SDL support & ask if they have guidance on this in the "User Interface update for SDL Tridion 2011 SP1". – Mr Smith May 20 '13 at 12:36
  • FYI, the content in question is XPM enabled in IE9, but not Chrome 26. – Mr Smith May 20 '13 at 17:42
4

It sounds like you have XPM set up correctly since you can see borders on other components, so some part of your front end code maybe conflicting with the XPM layer.

To identify the code that is causing the conflict you could use either Firebug in Firefox, or the Developer Tools in Chrome. Playing around with the HTML and CSS 'live' can sometimes help you see whats going on.

Sometimes it's easier to change the HTML/CSS of your site than it is to start trying to change the behaviour of XPM.

One approach is to strip your troublesome Component Template back to basics and republish, and then to gradually re-add markup back in so you can identify exactly what it is thats causing the conflict.

Hope this helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.