6

I have tried setting up the SDL Web 8 as per the documentation and following the instructions setting up the Discovery Service HERE.

The installation of the SDL Web Discovery Service completes successfully, however, it comes in STOP state in a moment after installation or after starting it manually. The logs for the discovery service shows the below error:

2015-12-28 21:21:34,686 DEBUG ClassPathBeanDefinitionScanner - Identified candidate component class: URL [jar:file:/C:/SDL%20Web%20Roles/discovery/services/discovery-service/web-readwrite-filter-8.1.0-1219.jar!/com/sdl/web/readwrite/rules/RulesConfigurationResource.class]
2015-12-28 21:21:34,842 DEBUG AnnotationAttributesReadingVisitor - Failed to class-load type while reading annotation metadata. This is a non-fatal error, but certain annotation metadata may be unavailable.
java.lang.ClassNotFoundException: org.springframework.security.config.annotation.web.configuration.EnableWebSecurity
    at java.net.URLClassLoader.findClass(Unknown Source) ~[na:1.8.0_60]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.8.0_60]
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[na:1.8.0_60]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.8.0_60]
    at org.springframework.core.type.classreading.RecursiveAnnotationAttributesVisitor.visitEnd(RecursiveAnnotationAttributesVisitor.java:47) ~[spring-core-4.1.7.RELEASE.jar:4.1.7.RELEASE]

I have tried putting up the spring-boot-starter-security JAR file as well, but the error did not resolved.

Any help in this regard would be appreciated.

  • You forgot to link to the instructions you followed :) – Peter Kjaer Dec 29 '15 at 8:21
  • Could you give us more information about the environment you are using? single-machine? capabilities in the cd_storage_conf? – Raúl Escudero Dec 29 '15 at 9:34
  • Peter: Thanks, I have updated the question. Raul: It is the Single Machine one. I am following the docs.sdl.com for Single Machine Installation instruction (as in the link above) and using the Capabilities mentioned there – Pankaj Gaur Dec 29 '15 at 9:37
3

The service should have all of the files it needs, with the exception of the cd_licenses.xml file that you need to provide.

If the service stops shortly after starting, I recommend running it in a command-line first to see exactly what goes wrong. In other words, run "start.ps1" in PowerShell instead (or "start.sh" if you are on Unix). The error message should also be in the logs, of course, but it's possible that something goes wrong that prevents it from logging it correctly.

  • Thanks Peter. Yeah, I had tried that already and the error message in the Log (as mentioned above) and the error message when I try to run the service in command line using start.ps1 is same – Pankaj Gaur Dec 29 '15 at 9:38
  • Is there a list of those dependencies? I had copied and paste the whole folder in the Standalone folder for the discovery role from the Installation Media – Pankaj Gaur Dec 29 '15 at 9:39
  • Those are all of the dependencies. Copying the whole folder is the right thing to do and aside from the license file is the only thing you should need (aside from Java 8 but it looks like you are already running that). – Peter Kjaer Dec 29 '15 at 9:45
  • Perhaps it is a permissions issue, whereby it cannot load those files? Or maybe they are blocked by Windows and you need to Unblock them? – Peter Kjaer Dec 29 '15 at 9:45
  • I checked and Unblocked all JAR files manually - the problem is intact. Can't visualize any other permission related issue :( – Pankaj Gaur Dec 29 '15 at 10:43
2

I have faced the same problem at the time of installation. Later I found the issue is related to the SQL Server Port. Go to the SQL Configuration Manager and check the TCP/IP port is assigned to 1433 or not ? if not, Then just assign 1433 as a TCP/IP port and restart the SDL web services. Hope it will resolve your problem.

enter image description here

  • Thanks Sayantan, unfortunately, this is not the case with me as all setup as expected. – Pankaj Gaur Jan 2 '16 at 8:31
  • Thanks, that's correct. SQL named instance had a different default TCP/IP port configuration. Just assign 1433 as a TCP/IP and it works. – DanielGLB Jul 1 '18 at 9:14
2

+1 for Sayantan answer, because this is the most probable root cause if you are installing Web 8 on named instance of SQL Server Express Edition. Default port for SQL Server database(1433) doesn't apply automatically to Named instance of SQL server express edition. I am posting this as an answer to share all the steps I followed to debug.

Generate Discovery service log in Debug mode by changing log mode in logback file. When you start the service again it will show you the message of TCP/IP port connection issue.

Steps to fix the issue:

  • I am not sure about this step is required but you may need to start SQL browsing if already not started. You can check in log if it is mentioned there.
  • Enable TCP/IP protocol present in Protocol tab showing in Sayantan post.
  • In configured IP addresses assign 1433 port IPAll, as shown in Sayantan answer.
  • Restart the SQL server service.

If your issue is because of SQL server glitches, hoping this response help you. Please share if you are still facing the issue after following the steps or there is another cause of your issue. Best of luck :)

  • Thanks Muku, although these were already set as expected and the issue still persists – Pankaj Gaur Jan 2 '16 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.