2

I am trying to get prepared for the recreation of the indexer instance. One of the steps that I should get is to identify the port number that the sync server listens.

The tutorial here suggests;

Execute

bin/deployment-agent-client --location INDEXER_HOST get-option INDEXER syncserver_serverport

However, when I issue the command, it returns nothing. Am I doing something wrong? ./bin/deployment-agent-client --location localhost get-option - syncserver_serverport

topology.txt

instance name | host | preset | indexer | comment

indexer|localhost|7|-|comments

  • Is the name of the machine with this indexer literally called "host" (or do you have a hostfile entry with this name pointing to it)? If not, that typology file is wrong. Most likely you meant to run the indexer instance on the current machine, so it should have said "localhost" instead of "host". – Peter Kjaer Dec 31 '15 at 8:27
  • You're right, it is localhost :)) . I edited the question. – shamaleyte Dec 31 '15 at 9:01
  • Have you chequed the syncserver service? have you looked at the logs in ../data/instances/indexer/log/syncserver.log Maybe it's not starting as it must. Why the number "7" in the topology.txt? are there 6 previous instances in that host? Have you chequed th url localhost:8177/instance/indexer? That gives you the ports user by the instance servers (maybe it's the same as the intance.conf) – Raúl Escudero Jan 3 '16 at 10:02
1

You are supposed to replace INDEXER_HOST with the name of the machine where the indexer is running, and INDEXER with the name of the relevant indexer instance.

For example:

bin/deployment-agent-client --location pkjaer.sdl.com get-option SmartTarget syncserver_serverport

Or in your case (based on the typology file you showed):

bin/deployment-agent-client --location localhost get-option indexer syncserver_serverport

Don't forget that if you are on Windows you should use a backslash instead of the forward slash:

bin\deployment-agent-client --location localhost get-option indexer syncserver_serverport

When it works, it will return the port as well as the word OK right after it:

8100OK

(don't ask me why it doesn't at least separate them with spaces -- that's just Fredhopper for you :))

  • Thanks for the answer Peter. However it returns only "OK" as the following . Maybe my conf. is corrupted ? . When I check the instance.conf of the indexer, I am able to see the port number though . Still something is wrong with the way I am running the command. -bash-4.1$ ./bin/deployment-agent-client --location localhost get-option indexer syncserver_serverport OK – shamaleyte Dec 31 '15 at 9:05
  • I don't know exactly what that means, then, but maybe you just don't have a sync server running on that machine? – Peter Kjaer Dec 31 '15 at 13:13
  • Not sure what was broken, but I had to eliminate the errors I had in the logs ( such as Socket accept failed java.io.IOException: Too many open files ) and then retry the steps given in fredhopper.com/learningcenter/display/learningcenter/… . I started re-indexing and finished it successfully. This time when I check the following command; I got the port number with Peter's suggestion. Even though I had the port number in instance.conf, the command returned nothing because the configurations were broken somehow. Fixing them helped recognition of the command. – shamaleyte Jan 5 '16 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.