5

Currently we are setting up the ECL provider for Media Manager with Tridion 2013 SP1 HR1. We followed the SDL install instructions and configured the certificates as it should be. Only when accessing the stubfolder in the GUI we don't get the assets from Media Manager.

In the log files I see timeouts:

2016-01-06T10:36:45 TcmServiceHost  6   The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:00:10'.
   at System.ServiceModel.Channels.StreamConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   at System.ServiceModel.Channels.SessionConnectionReader.Receive(TimeSpan timeout)
...

In the ECL and STS configs we have the endpoint: https://[TENANTNAME].sdlmedia.com/WebServices/MediaManager2011.svc

Probably the connection problem is caused by the fact we haven't configured our corporate proxy server.

Does anybody have the MM connector working with a proxy? And how can we configure it?

  • This might help! github.com/buildingblocks/youtube-ecl-provider/pull/1/… – Shiva Jan 6 '16 at 16:14
  • First check whether your proxy is white listed or not? If not, then provide the details to media manager support team and ask to white list your proxy. Once it is done then go to the Proxy settings in Control Panel and set you proxy. – Sayantan Basu Jan 7 '16 at 4:08
  • @Shiva: thanks for sharing. I will take look in depth later, but I see quickly that they have implement proxy conifiguration in their provider code. I don't know if the MM provider delivered by SDL has the same options? – Guus Beltman Jan 8 '16 at 9:13
  • @SayantanBasu: I will check this with the support team. Thanks for the suggestion! – Guus Beltman Jan 8 '16 at 9:13
3

Locate the ServiceEndPoint element for your mountpoint in ExternalContentLibrary.xml, then add the following attributes:

  • proxyUrl
  • proxyUserName
  • proxyPassword

The last two being optional.

  • Thanks Lars! I will try it next week, looks like the solution I was looking for. Maybe this feature should be added to documentation for the MM connector on docs.sdl.com? (At least I could not find it there..) – Guus Beltman Jan 9 '16 at 15:54
  • This solved the problem. Extra note: the proxy url has to be in the format http://[proxyserver]:[port] – Guus Beltman Jan 11 '16 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.