We have just installed SDL Web 8 on a Windows Server 2012 R2 server with SQL Server 2012 SP2 for the database. We have also installed the the core content delivery standalone microservices (Discovery Service, Session-enabled Content Service, Content Deployer).

But we are getting the following error with the Add-TtmCdTopologyType PowerShell command

Add-TtmCdTopologyType : Authorization has been denied for this request.
At line:1 char:1
+ Add-TtmCdTopologyType -Id DEV -Name Development -EnvironmentPurposes "Developmen ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
   + CategoryInfo          : NotSpecified: (Tridion.Topolog...logyTypeCommand:AddCdTopologyTypeCommand) [Add-TtmCdTop
  ologyType], DataServiceException
   + FullyQualifiedErrorId : Tridion.TopologyManager.Automation.AddCdTopologyTypeCommand

We have added the user running the command to all three Topology Manager groups as well as Administrator group.

Does anyone know what the issue is here and how to solve it?

3 Answers 3


I ran into this today and the solution is a little obscure:

I had to shift+right-click on my PowerShell console and choose "Run as different user" and then enter my credentials again. Yes, I logged in as myself again.

So even though I used the exact same user as when I ran it before (and who I have used successfully in the past without issues), it only started working after I went through this 'Run as different user' dialog.

This is made even harder to troubleshoot by the fact that it does apparently use the correct user when logging the error in the Event Viewer.

Anyway, I'm told this is a Windows (or PowerShell) issue where there's a mix-up with the credentials in some cases.

  • 2
    Also needed to pin the PowerShell ISE to the Start screen in Windows Server 2012 and then the right-click showed 'run as a different user'. If you right-click on it from the search results, you can run as admin, but not as another user.
    – robrtc
    Commented Apr 15, 2016 at 6:03

This suggests an issue with the authentication between the Topology Manager and the Discovery Service. Are your -ClientID and -ClientSecret values aligned with the cmuser account within your discovery\config\cd_ambient_conf.xml file?

See the responses to SDL web8 - Issue with adding a website as well.


Since the error occurs when adding a Topology Type (which doesn't result in communication with either CD or CM), the problem seems to be that the user who executes the PowerShell cmdlet is not authorized to perform that command.

By default, you need to be in the Windows Administrators Group and run PowerShell as Administrator to be able to make changes in Topology Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.