5

I have recently installed the SDL Web8 Content Service as a standalone micro service. I set the LOGGING level to trace. When I try to start the service, it shuts down after about 10 seconds. There are a ot of log entries, but the final 6 lines are:

2016-01-22 07:58:45,265 INFO  ODataWebserviceExtensionManager - Finished loading webservice extensions
2016-01-22 07:58:45,307 TRACE ODataWebHandler - Initializing extensions.
2016-01-22 07:59:28,423 DEBUG TridionEntityTypeRegister - Registering entity data models
2016-01-22 07:59:28,895 DEBUG TridionEntityTypeRegister - Registering metadata functions
2016-01-22 07:59:30,318 DEBUG AmbientServiceProvider - Initializing Ambient Data Framework Service
2016-01-22 07:59:41,706 DEBUG ODataContextListener - OData servlet Context was destroyed, shutting down StorageManagerFactory

I also tried running the service using the start.ps1 PowerShell script, but I see the same problem.

Can anyone suggest what may be causing this, or which other log files I should look in to try and solve the problem?

10

If you don't see any other errors, I'm guessing it is a port conflict. The default port for the Content Service is 8081; perhaps something else on your machine is already running on that port.

You can check that using PowerShell:

Get-NetTCPConnection | where { $_.LocalPort -eq 8081}

If that returns anything, there is something running on that port.

(You can also use netstat -ao if you prefer)

Edit: Another possibility is that you haven't added a valid cd_licenses.xml file to the config folder of the server. Although that does normally show up in the logs and when you run 'Start.ps1', it can be easy to miss.

  • 3
    You are my hero @Peter. It feels like this would be a good thing to log in a future release/hotfix. – Chris Summers Jan 22 '16 at 16:27
  • 1
    I agree. There shouldn't ever be a case where the service stops but doesn't clearly log what the problem is. It's been noted and should be addressed in the future. – Peter Kjaer Jan 22 '16 at 20:11
2

I had the same issue. I realized that the content service has a dependency on the directory service name... in the installService.ps1, I had to modify this line

$arguments += "++DependsOn=SDLWebDiscoveryServiceLive"

as I had changed the default name of the discovery services.

1

I have also faced the similar issue when I was installing my content delivery components for single-machine installation by following this doc. I was verifying my installations after installing discovery, deployer, session-enabled content service. My discovery service was not running, whenever I was starting the service it shuts down after few seconds without logging any error. I tried multiple time but it was showing same behavior. To fix the issue I followed these steps:

  • Restarted the installation server.
  • Started the discovery service again.
  • Registered the discovery service by running the command java -jar discovery-registration.jar update. Till that time I had not run this command.

Your issue may be different but can you check by following these steps if that work for you also..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.