We are facing challenges while updating schema fields. Below is my scenario:

We have updated my embedded schema by adding new drop down text field. After this, opened existing component as well as new component but unable to get newly added field. We tried to open with incognito window and cleared all browser cache but still no luck.

After referring Component not updating after update to embedded schema field, we tried to set max-age attributes value to "1" but my config value is commented as shown below:

enter image description here

Can anyone help on this.

  • Did you try from a different browser? Is the new field added successfully to your Schema? Commented Jan 25, 2016 at 13:06

2 Answers 2


We have faced similar issue in the past and the solution is to update the main component schema explicitly. When I say 'explicitly', it means add some space and remove in schema description and save it. This will sync all the changes as needed and component will reflect new bucket.


You can change the max-age by just un-commenting it like this:

<cfg:cache implementation="Tridion.ContentManager.Schema" max-age="1" />

That said, I don't really feel like this is a good idea most of the time. The cache is very useful when your Schemas are not changing -- which should be the majority of the time. It's only annoying while you are still developing your Schemas. So you can turn it off while that is going on, but don't forget to set it back when you are done.

What usually works is to just press F5 on the Component editing screen (or wherever you are not seeing your changes). Don't hold CTRL or SHIFT or anything else -- just press F5.

If that still doesn't work, just make sure you close all of the tabs / windows in your browser that have the CME loaded. Then load the CME again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.