2

We are facing caching issue when we fetch Dynamic Component using DD4T’s getComponent function of GenericComponentFactory class. We are getting old data even after the content is updated and published. We tried the following to overcome this issue, but it still persists.

  1. Removing caching from web application. Restarting the application also gives the old values so probably it’s not related to web-application side caching.
  2. Removed caching from cd_storage_conf.xml file in app and broker deployer.
  3. Using NoCacheProvider in dispatcher servlet.

We are usign dd4t 1.31 api Note: Directly hitting the broker via broker-query gives the updated values.

1

You can disable your cache from storage config in two ways

  • Make sure broker DB is correct :)
  • You can stop caching at global level <ObjectCache Enabled="false"> or individually for required item, in your case DCP, in storage config.
  • You may have to optimize following parameters or other settings mentioned at following

    cache.dependency.ttl = 20
    Cache.expired.ttl = 20
    cache.ttl = 20
    

    you can refer this link for more settings.

| improve this answer | |
  • Thanks,, I already did these as mentioned in question too. – Harish Sharma Jan 28 '16 at 18:10
  • did you check the link? – Raj Kumar Jan 28 '16 at 18:40
  • if this is something live, check CDN/Akamai – Raj Kumar Jan 28 '16 at 20:24
  • its is dev.... No CDN is configured yet – Harish Sharma Jan 29 '16 at 2:22
  • 1
    That was raised by me only few months back... That issue was something diffferent then posted this question – Harish Sharma Jan 29 '16 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.