recently I have changed the Tridion Application Pool User to domain user. When I try to grant on RSA KEY I obtain the next error:

c:\Windows\Microsoft.NET\Framework64\v4.0.30319>aspnet_regiis -PA "TridionRsaKey Container" "domain\username"

Microsoft (R) ASP.NET RegIIS version 4.0.30319.34209 Administration utility to install and uninstall ASP.NET on the local machine. Copyright (C) Microsoft Corporation. All rights reserved. Adding ACL for access to the RSA Key container... No mapping between account names and security IDs was done. (Exception from HRES ULT: 0x80070534) Failed!

Could any helps me please? Thanks!

  • Are you running aspnet_regiis in a command prompt with "Run as administrator"? Commented Feb 5, 2016 at 12:35
  • 1
    yes. Also I tried with the same user who ran the tridion installer Commented Feb 5, 2016 at 12:38

2 Answers 2

  • Open PowerShell ISE AS Administrator

  • Paste in the command Below and execute

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -pa "TridionRsaKeyContainer" "Yourdomain\UserName"


Use PsExec to run the command as the SYSTEM user.

PsExec -i -s cmd.exe opens a command prompt as the SYSTEM user. Use this to run the aspnet_regiis command.

  • It worked like a charm!
    – DanielGLB
    Commented Feb 8, 2016 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.