On a Web8 XPM set up using DXA 1.2 I am getting the following error from Update Preview:

Unable to update the changes using OData Service. The remote server returned an error: (406) Not Acceptable.

I am using Legacy Publishing for a Proof of Concept. I've tried changing the URLs for the Content service and the token service.

If I remove the Token Service URL from the Publication target I get

Unable to update the changes using OData Service. Unable to get Access Token for OData Service. One or more errors occurred. {"timestamp":1455833422115,"status":404,"error":"Not Found","message":"No message available","path":"/access_token.svc"}

So I assume OAuth is actually enabled.

I've checked that the cd_ambient_conf.xml has OAuth enabled set to true.

Any ideas?

Update: Addition info on settings

I've changed the OData URL to be the V4 endpoint and now I get this error:

Unable to update the changes using OData Service. An error occurred while processing this request. The expected content type for a batch requests is "multipart/mixed;boundary=batch" not "application/xml;charset=UTF-8".

Switching back, is the same as before.

Publication Settings

OData settings

  • Can you show how your Publication Target is configured? Commented Feb 19, 2016 at 8:52
  • BTW: note that DXA 1.3 officially supports SDL Web 8 and has OOTB support for the new publishing model. Commented Feb 19, 2016 at 8:55
  • @RickPannekoek Added. We're using Legacy publishing to make it easier to set up for this demo. Publishing does work to this target. It's just Update preview that doesn't. The weird thing is the Session Preview log files look OK. As in I can see Sessions being created etc. Commented Feb 19, 2016 at 13:49
  • Funny title... "not that error".... but not very helpful. How could we make the title more informative? Commented Feb 22, 2016 at 14:25

1 Answer 1


The "Content Delivery Endpoint URL" should be the URL of your PreviewWebServiceCapability (see cd_strorage_conf.xml of your Discovery Service), not of the Content Service (V2 nor V4).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.