5

When I create a new page using the existing page types present in DXA 1.2 the components still get created in 400 Example Site Publication instead of getting created in 100 Master publication. I have already updated the blueprint context settings please find below the screenshot of the same. enter image description here

Am I missing some step here ?

  • have you done any modification/ localization with items used in the page type in question? – Raj Kumar Feb 24 '16 at 7:10
  • I am using "Article Page" page type and I have not done any modification/localization.The blue print is the standard blueprint which comes as part of the DXA setup. – user3560198 Feb 24 '16 at 7:18
  • there is only one component on this page type, right? also check your settings are saved to honored by XPM. – Raj Kumar Feb 24 '16 at 8:34
4

Just checked the \400 Example Site\Building Blocks\Content\_Cloneable Content content, actually Article Component attached on the Page type is created itself in 400 Example Site. so you will get your new page's component created in 400 only.

if you create this component in master, you will get desired results.

  • Hello Raj, I have tried doing the suggested changes. Still facing the same issue.I created new page type with the components coming from 100 Master publication. – user3560198 Feb 24 '16 at 12:54
3

In DXA 1.2, the OOTB Page Types and Content Types are defined in the 400 Example Site. XPM doesn't allow you to create the Pages/Components higher in the BluePrint than where the Page/Component Types are defined.

In DXA 1.3, the Page/Content Types are defined higher up in the BluePrint (in a new Site Type Publication), which makes them re-usable and also allows you to create the Pages/Components higher up in the BluePrint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.