8

I am trying to create a standard BluePrint structure in Tridion 2013.

I am getting some incredibly weird behaviour

I have created a (001) Master publication with an empty 'root' SG - I would like to add a child to this, so go through the 'Blueprint hierarchy" option on the menu. It shows :

LEVEL 0 - (001) Master

Adding a child pub from here (002) Schema now shows :

LEVEL 1 - (002) Schema directly underneath.

I can not for the life of me add any further children to this - all the options are greyed out for adding children - going through the 'old' way of right clicking the pub and then going through the Properties / Blueprinting tab to add a new child just opens a popup window which then closes immediately.

What have I done wrong?

5

You can only add a BluePrint Parent in the Publication Properties when creating a new Publication.

You can never add Children, that is done by adding a Parent to them (the BluePrint hierarchy view shows you an option of adding a Child, which basically will open that Child Publication and add your current one as a Parent, or when adding a new Child, it will create a new Publication), but a first parent can only be set at creation time of a Publication, if one hasn't been set, that Publication can never be made part of a BluePrint.

Adding additional Parent Publications or Children in the BluePrint Hierachy view can only be done if the Publication you want to add is part of the current BluePrint chain, so it must already have a mutual parent. For the first child of your upmost parent, this means the option to add a parent is available, but if there are no publications in the same level (shown right next to it), the window will close directly again, as there is nothing for you to add.

  • There's a possible bug here then, because the Add Child option worked for me the first time after creating the Master and then clicking "Add new child" to add the second level pub - it certainly seems to have screwed everything up now as I cannot add anything at all, parent or children! – mpaton May 22 '13 at 13:49
  • Can I also ask... why bother having the "Add child" function if you can't use it? – mpaton May 22 '13 at 13:50
  • I updated my answer to give more clarity on this (hopefully ;o) – Bart Koopman May 22 '13 at 13:52
  • if the options are not working at all anymore, maybe try clearing your browser cache and reloading the entire CME, could be that your newly added publications are not fully available due to the UI cache. – Bart Koopman May 22 '13 at 13:55
  • It's definitely "borked" - can I drop you a mail with some screenshots to show? – mpaton May 22 '13 at 14:08
3

Although this question has been answered now, it may be worth noting that you have add an (empty) Structure Group to the root Publication, before you can then add any child Publications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.