2

I want to configure DD4T 2.0 alongside Tridion 2013 SP1, wondering if it could be configured with MVC 3 and VS 2010 as I am not able to find any document reference to this. Please help with any guide to it.

  • 2
    1 question to this: why? Those tools are nearly 6 years old. – Rob Stevenson-Leggett Mar 2 '16 at 20:16
  • 1
    The requirement is that sort of. – Stark Mar 3 '16 at 2:31
2

These are very old versions and no longer supported by MS as also mentioned by Rob in comments. so not recommended. But as your asked my observations are as follow.

I checked DD4T 2.0.0 beta source code (which i have on my machine). Up-to this version System.Web.Mvc 3.0 is used and target .net framework 4.0 , then i think it matches your requirements.

but DD4T version 2.0.7 or later requires MVC4 or MVC 5.

My personal view, you can do some homework, download open-source code and target using your required framework and resolve any error (i don't expect much errors/warnings as up-to major version 2.0 is using mvc 3.0 and .net 4)

  • 1
    I wouldn't recommend using DD4T < 2.0.7 – Rob Stevenson-Leggett Mar 3 '16 at 18:33
  • @RobStevenson-Leggett i agree , but isn't it a minor version so the updates. – Raj Kumar Mar 4 '16 at 9:53
  • Pre 2.0.7 is considered "Beta" IIRC – Rob Stevenson-Leggett Mar 4 '16 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.