4

For customers on SDL Tridion 2011 (GA), what versions of DD4T do they need for an upgrade to either SDL Tridion 2013 (SP1) or SDL Web 8.

Also, does DD4T handle the new CIL/CIS architecture in SDL Web 8? I'm assuming they'd use mostly the same DD4T code in their Web Application, regardless of where they use the web service or in-process approach, right?

7

For the Java version of DD4T:

Tridion 2011 to Tridion 2013

No upgrade needed. DD4T versions 1.31 and 2.0.0+ will work with Tridion 2013 as well, with one important note: The DD4T web application will need to be compiled against JDK 7 and the Tridion CD API version 7.1.0 instead of version 6.1.0.

Tridion 2011/2013 to SDL Web 8 In-Process

The same is true here, but the web application needs to be compiled against JDK 8 and the 8.1.0 Web 8 dependencies. It is however highly advised to at least move to DD4T 2.0 in order to make full use of the new stuff in the API and to be able to switch to the new REST architecture much easier. Besides that, DD4T 2.0 of has many many fixes, features and performance improvements over DD4T 1.

Tridion 2011/2013 to SDL Web 8 CIL / REST

DD4T has CIL / REST Support from version 2.0.4 and upwards. The recommendation is to switch to this base version at the earliest convenience if you want to fully use CIL with the lightweight client. The REST scenario takes all the open dependencies delivered by SDL from Maven Central, which makes it much easier for developers to work and this alone should be a reason to move to Web 8 / DD4T 2.0 ;)

One other important note: as of version 2.0.4, the project is using Maven Profiles to distinguish between the different scenarios and Tridion versions:

# Tridion 2013
mvn clean install -Pcd-7.1.0

# SDL Web 8 CIL / REST
mvn clean install -Pcd-8.1.0

# SDL Web 8 In Process
mvn clean install -Pcd-8.1.0-inproc

..so support for all versions from 2011 onwards is still present in the DD4T providers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.