1

I'm having trouble connecting my deployer to a SQL Server named instance. It keeps saying 'login failed', even though I can log in to the database with SQL Server Studio using those same credentials.

I've tried the following:

<Property Name="serverName" Value="SERVER\INSTANCE"/>

This gives the error: Login failed for user TridionBrokerUser

<Property Name="serverName" Value="SERVER"/>
<Property Name="instanceName" Value="INSTANCE"/>

This gives a different error, something like 'cannot open connection'.

Also tried forward slashes instead of backslashes (the client is on Linux), but nothing works.

Is this scenario supported at all? If so, how?

  • I am using named instance on my test environment like in your first quote. Please also check <Property Name="portNumber" Value="1433" /> property. Most probably named instance has non-standard one. – Stanislav Maryenko Mar 10 '16 at 14:53
  • Thanks, Stanislav. It was indeed a non-standard port, as the DBA was kind enough to tell me after 2 hours of messing about.. If you post this as an answer I will accept it. – Quirijn Mar 10 '16 at 16:45
2

Named instances are usually installed on non-stardard ports. Please also check that

<Property Name="portNumber" Value="1433" />

property is properly configured.

| improve this answer | |
1

Please confirm that you are using a FQDN or IP within the serverName property. Particularly if you are on Linux, as you may well not be able to access a Windows Domain using without it.

See https://msdn.microsoft.com/en-us/library/ms378988(v=sql.110).aspx for further connection details.

Also try double backslashes between the server name and the instance.

| improve this answer | |
  • Thanks for the suggestion, Bengineer. It turned out to be a port issue (see my comment under the question), and I am able to connect now using the simple server name, single backslash, instance name (so: SERVER\INSTANCE). – Quirijn Mar 10 '16 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.