I have live and staging services installed on the same server (CDaaS). If I publish a Page to both live and staging I get a success message in the queue. In the database I see the page in live (broker_live) but not in staging (broker). I tried to restart the staging services but I get the same result. If I restart the server then try again the publish works for staging; however, after a short while I face the same situation again.

My discovery and preview services seem fine, I can navigate to them in the browser.

Services: Live Discovery Live Deployer Content Live Context Staging Discovery Staging Deployer Preview Staging Context

1 Answer 1


On further investigation I noticed that I hadn't provided different directories for the deployer's queue. If implementing two deployers on the same machine, in my case one for Staging and one for Live, then each must have its own queue directories.

Open the Live Deployer's config/cd_deployer_conf.xml and change the following:

enter image description here

In my environment I left all Staging services with default configuration settings and appended 'live' to all my Live configurations.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.