0

I'm having issues with a cloned 2013-SP1 environment (specifically the Content Manager server). We've done this in the past without really any significant problems, but this time things aren't going so smoothly as there are more variables that are changing with the new server - server name, same user accounts, but different passwords, etc.

The first thing I figured I needed to do was to update the licenses, then update the COM+ identity and then change settings in the Tridion Configuration Manager. When I tried to access the database and other settings in the configuration manager, I receive the following error:

Could not read configuration item... [user] has no permission to access the protected configuration section.

I've attempted to run the following as suggested in another StackExchange question:

aspnet_regiis -pa "TridionRsaKeyContainer" "<domain>\<account>"

But doing that results in the following error:

The RSA key container was not found.

I also tried to run MMC as the MTSUser, but I still get the protected configuration error.

I'm hoping I don't need to reinstall the entire Tridion stack for this new environment, but I'm beginning to fear I will. Any help is greatly appreciated.

  • 2
    Maybe this is helpful: kahwah.me/2014/6/… – Albert Romkes Mar 14 '16 at 6:45
  • Did you try running the command prompt as Administrator and then run the aspnet_regiis command - In my opinion, you must resolve the error you are receiving in executing this command – Pankaj Gaur Mar 14 '16 at 7:11
  • @PankajGaur - I did attempt to run command prompt as Administrator to no effect. – J Stuart Mar 14 '16 at 18:03
  • @AlbertRomkes - That link does look very helpful. My understanding is that I need to go and decrypt a copy of this file on the original server. Once its decrypted I take it to the new server and re-encrypt. I think the renaming of the server would have caused this potential issue. I'll report back my findings. – J Stuart Mar 14 '16 at 18:06
2

Albert got me going in the right direction, although that specific direction didn't pan out. I was able to decrypt the Tridion.ContentManager.config file on the old server, but when I attempted to encrypt one of the sections on the new server, I received an error that the configuration already existed (don't have the exact error anymore).

I think my underlying issues were two-fold: changing the server name & environment resulted in new keys and I lacked permission to the TridionRsaKeyContainer to update the keys or add users.

I followed the process indicated on the TridionDeveloper blog, but had to leverage PSTools as instructed on rjin's blog to get the right permissions for some steps (otherwise I would see errors like "RSA key container not found").

I'm now able to access the configuration on the new server. Cheers for the help. I think if I'd used the PSTools with Albert's suggested approach it would have worked as well (re-encrypting the sections with the local machine's keys as opposed to replacing the local machine's keys as I've done now).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.