2

I'm currently working on an XPM GUI extension that customizes the component library to insert content via XPM

enter image description here

I've found out that this list of components gets rendered by an XSLT stylesheet called DrillDownlistTemplate.xslt that can be found here : [tridion-install-dir]\web\WebUI\Core\Controls\DrilldownList\

Currently, i've almost achieved what I want to do by editing the DrillDownlistTemplate.xslt file itself, which is off course not the correct way to do it, as it's not supported to change any core tridion files.

I'm wondering if there is a way to override this xslt file (replace it by our own) to do some custom rendering.

  • Out of curiosity, what are you changing in the library? :-) – Alvin Reyes Mar 18 '16 at 19:54
  • We want to show a specific thumbnail per component to visualize the contents of the available components. For this, i've written a data extender that adds the icon to display per component. I now just need to change the xslt to make it render the new icon, instead of the default one – Harald Hoffelinck Mar 21 '16 at 8:38
5

Try this: "Extensibility | XSLT inclusion"

  • Thanks, that looks promising. I'll try it and i'll let you know when I got it to work – Harald Hoffelinck Mar 18 '16 at 17:42
  • You should copy the relevant bits from the link in here -- as the link might not be accessible in the future. – Peter Kjaer Mar 21 '16 at 6:16
  • I've tried to implement this, but it looks like this xslt inclusion is not added to every xslt file. For example, i manage to add it to this one "WebUI/Editors/SiteEdit/Controls/Gallery/GalleryTemplate.xslt", but not to this one (the one I need to extend) "/WebUI/Core/Controls/DrilldownList/DrilldownListTemplate.xslt" – Harald Hoffelinck Mar 22 '16 at 14:00
  • Extending core resources is bit more tricky. However, example from the article extends core resources as well. Check link below to GitHub project. I think the moment is to set <ext:editorextension target=""> – UI Beardcore Mar 22 '16 at 15:36
  • thanks, setting the target="" instead of target="CME" or target="SiteEdit" worked indeed. – Harald Hoffelinck Mar 22 '16 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.