7

I have installed my CM and Topology Manager on non standard ports. When I run the Add-TtmCdTopologyType command in powshell, it tries to connect to http://localhost/ttm201501, but my Topology MAnager is at http://localhost:82/ttm201501. How can I change this?

PS C:\Users\tridion> Add-TtmCdTopologyType -Id StagingTopologyType -Name StagingToplogyType -EnvironmentPurposes "Stagin
g"
Add-TtmCdTopologyType : Error occurred while attempting to communicate with Topology Manager Service at
'http://localhost/ttm201501'. The server returned the following response code: 404 (NotFound).
At line:1 char:1
+ Add-TtmCdTopologyType -Id StagingTopologyType -Name StagingToplogyType -Environm ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Tridion.Topolog...logyTypeCommand:AddCdTopologyTypeCommand) [Add-TtmCdTop
   ologyType], DataServiceException
    + FullyQualifiedErrorId : Tridion.TopologyManager.Automation.AddCdTopologyTypeCommand
12

It is an Environment variable called TRIDION_TTM_SERVICEURL

enter image description here

You can also add -TtmServiceUrl parameter to all your commands (but this is mostly used if you want to run Powershell script from another machine), for example

Add-TtmCdTopologyType -Id StagingTopologyType -Name StagingToplogyType -EnvironmentPurposes "Staging" -TtmServiceUrl http://host:port/ttm201501
  • Awesome, thanks for the fast response. Is this documented anywhere? I couldn't find it in the online docs! – Chris Summers Mar 25 '16 at 10:39
  • 3
    Looks like it is not documented ) – Stanislav Maryenko Mar 25 '16 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.